I have a Re-arm question.

gplus
(Jeremy Wasserstrass) #1

I have a Re-arm question. In changing to a Re-arm I can’t get my inductive prox to work for my Z probe. When I check the signal I get ~3.2v that drops to .2v when metal is present. Do I need to change my voltage divider setup? I have tried with and without a pull up sensor on Z-min. And if it matters I am trying to give Marlin 2. a try.

(Neil Darlow) #2

It appears that the Z-MIN input on the RAMPS 1.4 connects directly to the ATmega input. Any internal pullup, if enabled, in association with an external potential divider will determine the signal level.

Without knowing how your external potential divider is constructed it is difficult to assess the situation any further.

(Jeremy Wasserstrass) #3

Currently the divider is set with a 15k in the signal line and a 10k resistor between signal and common

(Jeremy Wasserstrass) #4

Okay, so I brought the 10k ohm up to 13.7k ohm which gives me a signal that is 5.3v when nothing is present at the sensor and .37v when there is metal present under the sensor.

(Jeremy Wasserstrass) #5

And it still doesn’t work.

(Neil Darlow) #6

In that case I would say the input isn’t configured correctly to act as your Z probe input.

The input protection diode is clamping the input to 5.3V when the sensor is off. When triggered it’s switching and the input falls to 0.3V so that’s OK.

Check through your Marlin configuration related to Z probe operation.

(Jeremy Wasserstrass) #7

Well just to test things I wired up a NO micro switch and that works to trigger Zmin. And from what I have been able to find the board should register something from above 3v dropping to below 1.5v as a signal. Unless there is something in Config.adv or a pins file I need to change I have tried changing everything except moving the prox to Zmax, I’m not positive enough on the sintax to do that at the moment.