I got myself a ESP8266-ESP07 board and read that fastled has support for it.

I got myself a ESP8266-ESP07 board and read that fastled has support for it. Whoho!
But as usual I run into trouble.
I can’t figure out how the pins work. Is there a special mapping in the arduino world that I don’t get?
Should for example GPIO13 work as pin 13 in the blink example?
#define DATA_PIN 13
//#define CLOCK_PIN 13
void setup() {
FastLED.addLeds<WS2812B, DATA_PIN, RGB>(leds, NUM_LEDS);

Yes there is a special map for the ESP8266 boards. Google to find it for your board. There is also a FastLED command which can help, I can’t remember what it is as I don’t use it, RAW PINS or similar. Search this forum for that one., this post might help https://plus.google.com/100734749368548768490/posts/LUx4iQCDMnK

I’m using Arduino 1.6.9 and what I can find when googling the pinout mapping is that from 1.6.1 the pin numbers should be correct to the numbers on the board.

Could it be a problem with Pullup/down or something like that?
Not using any breakout board. only directly connected to the ESP07 board.

Make sure you have connected to the correct end of the strip

Using a single led with the wire to the input pin.
Also tested a “normal” led with just on/off blink without success. Seems to be a problem with port mapping or something with output handling?

So there’s two primary mappings of pins that are used - there’s a raw pin mapping where the numbers used map directly to GPIO’s (e.g. pin 13 is GPIO13) and the NodeMCU pin ordering, where the pins are numbered on the board, and the number doesn’t line up directly to GPIO numbers. This was done, I suspect, so that you could have pins 0-10 to use, rather than having to remember that you really only have GPIO 0-5 and 12-16 available to you.

Which pin ordering it defaults to depends on what board target you’re selecting in arduino, which you haven’t mentioned - but I suspect you’ll want to add the line


before you include FastLED.h. Also, make sure that you have at least version 2.2.0 of the arduino esp8266 package.

To get the code to upload I use the Generic ESP8266 board.
Have not seen any information on the 07 module and what board else to use.
Adding the define on the generic board did not solve my issue.
My setup:
Arduino IDE 1.6.4 (switched back as I read somewhere it could be an issue)
esp8266 version 2.2.0
Board: Generic 8266
Flash mode: DIO
Flash fq: 40
CPU fq: 80
Flash size: 512
Debug port: disable
Debug level: none
Reset method: ck
Upload speed: 115200
Port: com12

Arduino 1.6.8/1.6.9 are the only ones I’ve done any testing of the esp8266 support with - and I’m currently using a bunch of 8266’s in active projects with both apa102’s and ws2812’s - can you turn on verbose output in Arduino options - build blink, and copy the entire build log up to http://pastebin.com so I can see what’s happening during your build.

I can get one of the 8266 examples to work, AdvancedWebServer.
Will see if I can get any information on the port mapping from that example.

Managed to add Fastled blink test to the advancedwebserver example. Will try to strip down the code to see what kind of requirement there is for port mapping.

The secret that I totally missed was to include the 8266 header
#include <ESP8266WiFi.h>
Solved my issues with getting access to the ports.
Now I can run the Fastled examples on the ESP-07