How do you get it to stop automatically applying a "work offset?"

How do you get it to stop automatically applying a “work offset?”

This changed with v4.0.735-109; are you up to date?

Yes, updated a couple days ago, and that’s when I noticed the issue. It shifts my documents around relative to the coordinate plane when given a G92.

Does it keep the grid aligned with the documents?

So it does.
So what’s happening here is that it’s shifting the white “machine borders” rectangle AND the camera around, which is easy to miss and confusing if you’re zoomed into the work.
So, since I’m using an elekslaser, my options are to either add end stops, requiring replacing the control board and every last wire on my machine so that I can home the axes and run 100% in absolute coordinates, turn off the machine borders indicator and ignore the three negative quadrants which you can’t turn off, or live with the camera jumping around without my permission.

My intent was for “showMachine” to be on for machines with endstops and off for machines without it. You’re hitting a grey area that I’m not sure how to handle well.

Maybe try this:

  • settings:
    • showMachine on
    • Machine Left X = Machine Lower Y = 0
  • Each time you start LW:
    • power down the control board
    • move it to lower-left corner by hand
    • power it up
    • connect

Now, from LW’s point of view, it should behave like a machine with endstops.