Homing problem .. solved?

I am building a Acro based laser etcher with a smoothie 4x and have not been able to properly home my setup for the last couple of days.

I finally did the smart thing and flashed the normal smoothieware edge (not cnc) and used the vanilla config with a few minor motor tweaks - and was finally able to see it home!

After comparing my ‘bad’ config and the working one, it turns out that leaving the extruder.hotend.enable set to true allows it home as expected? Setting this to false causes the board to freeze and disconnect after sending it home command on any axis.

Not sure if this is a known issue or if my setup is otherwise goofy. I am twinning the beta and gamma motors according to the wiki, so maybe that’s contributing to some strange edge case?

I mostly just wanted to share in case anyone else is running into this in the future.


Thanks for sharing :slight_smile: