Homing causes shutdown

I’m new here as will be evident. I have a new PROVerXL 4030 V2. It worked great the first few times I used it. Then all of a sudden when I home it, the z axis limit switch will click, back off as it should then lock the system. I’ve tried on different software. UGS, Candle, Easel. All with the same issue. I tried everything within my limited knowledge of the subject. No help in internet searches so far. UGS app keeps closing on me. All software has been uninstalled and downloaded fresh, some multiple times. New laptop PC.
Please help

Is something power cycling or causing a power glitch? Any odd output from the controller firmware on the ‘console’ window?

Not that I’m able to tell.

Does your machine do a homing cycle when it is powered on even without any software connected?

I don’t have an offline controller yet. I assume I would need that to home without software.

I’m probably wrong about that. Lol way too new at this

It has a controller box… turn the machine off, move the stepper motor knobs so that the milling head is 2 or 3 inches away from the limit switches, unplug the USB cable from the controller box and turn the machine on.

If it tries to move to the end stops then it has the firmware set to auto-home on power up. Otherwise it requires the USB connected software telling it to home the machine to set the 0,0,Zmax position.

And I would look at all the cable connections of cables moving when the Z axis moves if that really is the only thing moving when it “locks up”.

Not to mention, sometimes you just have to use the Unlock command on the software when you are ready to send commands( tool paths ) or manually command movement of the machine. Again, you should be seeing text output from your controller firmware on the command console window of the software you are using on your computer.

I don’t think i’m able to do that, but I will try when I get there in the morning.
The problem with using the unlock command is that when it does lock I sometimes have to reboot the machine and/ or software. Sorry, I guess I didnt mention that earlier.
I will try what you said in the morning. I really appreciate you taking time to help me. I’m also thinking that I might connect it to another computer or even try a plugging into a different outlet on a separate breaker. Might as well eliminate possibilities I have control of. Thanks again for the help.

You also might see a led come on at the controller indicating a fault. Usually, when the controller does not see an endstop switch when expected or sees an unexpected switch closure it assumes it is out of range and creates a fatal error by locking the controller.
You might also try testing the end stops to see if they are working correctly.

1 Like

I have checked and XYZ all trigger when manually activated. Z only shows “AlarmZ” when homing or when I jog Z+ until it contacts. The controller shows nothing and it does not move at all when powering up. I changed computers and power source. No difference.
Sometimes I can reset it using unlock button or soft reset button. Sometimes its a combo of the 2. Other times I need to disconnect to reset. Either way I need to perform that at least twice, lowering Z between before it unlocks enough to continue. The frustrating part is that it was working fine for a few test projects.

I removed and checked all the wiring/ connections. No issues

When it does home the 3 axis do you notice the X and Y axis moving to the home switch and then backing off a little bit or do they go and stop as soon as the switch is contacted? Many machines will be setup with the ‘soft’ endstops which will move to the endstop, then back off a few mm and go back more slowly to the endstop, contact it and pull off a distance set in the firmware.

They are handlded in settings $20 - $27 if the machine runs GRBL firmware as shown in this cheat sheet: https://www.diymachining.com/downloads/GRBL_Settings_Pocket_Guide_Rev_B.pdf