Hello, I just finished upgrading my TEVO TORNADO to an MKS GEN L Board

gcodeprintr-problems
gplus
(René Schmidts) #1

Hello,

I just finished upgrading my TEVO TORNADO to an MKS GEN L Board running Marlin 1.1.8. Before this I got the App a short try and it worked so far.
Anyway I´m new to using GCodePrintr…
Right now I´m not longer able to get a working connection from my phone, nor my tablet to the printer. It is realised by the devices finding automatically the baud rate, as well. Anyway there is no functionality after this.
Any help welcome :-]

GCodePrintr Problem Report

Printer Model:Tevo Tornado

Problem Description:

Version:de.dietzm.gcodesimulatorprinter V3.03
Device:samsung a3ltexx & Android 7.1.2 Lineage 14.1
Settings:
octohost=192.168.0.9:5000
tasker=true
resetoninit=true
printertype=Tevo Tornado
speedpercent=10
exttmpp1=185
octokey=
finishtone=content://media/internal/audio/media/47
logfile=false
tempwatch=10000
diameter=175
exttmpp2=200
usepresets=false
logo_checkbox=false
licensekey=Keinen
webserver=false
connectmode=0
bedtmpp1=50
wakelock=print
material=Autodetect
savefile=true
bedsize=300x300
networkrec=false
gcodefactory=1
paintahead=-16
paintextruder=false
pricekg=20
debug_checkbox=false
flipy=false
commtimeout=10000
otgfallback=3
singlelayer=false
baudrate=230400
movespeed=1000
homexypause=true
antialias=false
dualoffset=0:0
extrusionpercent=1
discovery=true
strictmode=true
extrudernr=1
painttravel=true
exttmpp3=250
flipz=false
autostartsd=false
roundbed=false
flipx=false
homexyfinish=false
stepsize=1
currency=€
screenon=true
checksum=false
renderprint=false
pricehour=2
thumb=2
bedtmpp3=90
prealloc=true
bedtmpp2=60
theme=5
extspeed=100
autozoom=false
screenfps=30
Display:
Metrics: DisplayMetrics{density=1.5, width=960, height=540, scaledDensity=1.5, xdpi=244.928, ydpi=243.839} densityDPI: 240 SmallestWidth:360 CalcSmallestWidth:360.0
Console Output:>Home X axis

Not connected
Set move distance to 1.0mm
Request access to USB device:VendorID:0x1a86 ProductID:0x7523 Device:/dev/bus/usb/001/002
Connecting to serial port (230400 baud)
Connection to printer failed

Please send the console output to the developer for support. (Context Menu -> Send support email)
Closing connection !
-----------------Debug Data---------------------------
Connected/Connecting/reset/resetting:false/false/false/false
Baud:230400
Last GCode:G0
Printing:false
Streaming:false
Serial Port:class com.hoho.android.usbserial.driver.CH34xSerialDriver
Temperature:
TempWatch Intervall:10000
Communication Timeout (occurrences):10000(0)
Last com. timeout linenr:0
Unexpected response:0
Swallow OK/Resend/Resendskip0/0/0
Read calls:51
Wakelock:false
Time since last send:1526663494606
Manual Print Queue:0
Auto Print Queue:0
Checksum enabled:false
LineNumber:0
LineTXIndex:0
Identifier:PrinterService
Last Garbage Collection:Fri May 18 19:10:52 GMT+02:00 2018
Init response:�BptX5BpGN&��B�bA�J�g~|�M�I:t~�p6�H�@�J�n�b%�EM�M�7��-Q�
�N�:~_&�C#�0^�bQB�%�e�AX�B�c�a�Mh�Ap|2EP:�P.�tt$]�r�J�B�H��HX&v�J�JB��\m0�ApC�:6X^�m�8p|(�J�J�B�BQ� TJp|4b �eN>}�jv�B�J�B�J�%x%�@��eN>m�b�Ka3.iCP�..iCKe�*�v�B�J�C�B�%�I�%HBp|PCmJ�6M�&�>O&�A�"e�6�egY�6bLe�{62�Ke&��3B�B�I�r�B� �B7�(�B��@�*�]i2J�R�A�zB�@�*&6|6N&Vr�B�C�(BAtt�P�JAtt<Mm�r�B�B�B�a5�\�H�B�B�-��~Z J�3�&�Ve:aB�ZJ��%���Jv��b�:\Ev�B�!�(��*��a�.��


0 Likes

(Mathias Dietz) #2

Thanks for using Gcodeprintr.
It looks to me that the baud rate is not detected correctly. Could you please set the correct baud rate in the preferences and try again ?

0 Likes

(René Schmidts) #3

@Mathias_Dietz Thanks a lot for your help. I finally got it :hugs:
The MKS GEN L is coming with the UART CH340 and GCodePrint is not accepting the baud rate oft 2500000 set in Marlin by default.
So i aligned the baud rate in Marlin to the APP and it is working as expected…

0 Likes