Grbl-lpc endstop firmware don't work

hi forum, I would like to know if the mks-sbase.bin firmware the endstops are enabled, because they don’t work on the k40, $20=1 $21=1 $22=1

no one can tell me if the swicth endstop on grbl-lpc of cprezzi are enabled on the firmware?

Yes, they work. I use my K40 with grbl-LPC on MKS SBase 1.3 with homing to top left.
Be aware that you need to configure homing before softlimits work. I never tried hardlimits.

1 Like

parameters $ 20 = 1 $ 21 = 1 $ 22 = 1 are enabled, I turn on the k40, it is in alarm, I write $ H and the y axis moves up and to the left, the problem that does not stop

My tip is to first configure homing only (with soft and hard limits disabled). And don’t forget to also configure the other homing settings ($23-$27). If that works, go a step further and enable soft limits.

Also check the grbl wiki about homing setup:

1 Like

i understood the problem that i could not do homing, lightburn uses inverted y axis, so you have to set LB in the lower left, and parameters grbl $ 3 = 3 and $ 23 = 1, now homing works


Lightburn does not use inverted y axis, it just expects to have the work origin (0,0) at lower left. Positive directions should always be x to the right and y to top!

This has nothing to do with the homing location (=machine origin). If your homing swithches are top left (like on most K40), then you need to configure homing x negative and y positive ($23=1).

If you correctly configure homing to top left, then the work coordinate after homing is x 0 and y max., so x0y0 is at the lover left.

Also see here:


Your grbl-lpc firmware when you load it 1 time on the mks has inverted y axis, you need to change $ 3 = 1 to $ 3 = 3

You might need to change the direction of some axes of your machine depending on your setup, because stepper motor direction is depending on wiring. You can either swap the wires on one stepper moter coil or change $3 accordingly.