Firmware disaster

Hi Everybody,
I uploaded the latest firmware to my Geetech A10M (Marlin) through “Update Firmware” function in Ultimaker Cura and I can’t connect to it anymore. The screen on the machine shows only hash symbols. Obviously this particular firmware wasn’t compatible with my machine. How can I revert to the previous version, when my computer doesn’t see it and I can’t control it straight from the control panel? I am so desperate, that I even consider buying a new cheap machine from a local shop to print this one part that I need urgently. Please help!

do you have a backup copy of the previous firmware?

If there is a uSD card in the machine then maybe there is a backup on there. But better if there is a uSD card you can put a backup copy of your firmware in the root directory( that’s the top level, not a directory called /root ) having a name of firmware.bin

when you restart the machine, it should upload the firmware.bin file and rename it firmware.CUR or something like that.

Welcome to Maker Forums…
Sadly to say This may be as big a disaster as you think… Lucky as you can be I think you can goto : ttps:// and look under A10M Firmware …
Happy trails.
P.S If that isn’t what you are looking for You may have to learn to build your own firmware from scratch

Check to make sure you are trying to connect to the correct COM port and have the baud rate also set correctly.

Were you able to get your machine up and running?

No, unfortunately not. I tried to start the machine with the previous (working) firmware on the SD card in the machine’s reader, hoping that it might prompt it to reload the firmware from it, but no joy. I connected a new machine to the computer with no problems, but the A10M is still not visible. A friend of mine took the machine to work on it and I don’t know yet the outcome. The problem is NOT the connection setting (port, baud rate, etc.) but that something went wrong after updating the firmware. The screen shows only bunch of “#” characters that don’t change, regardless of what I do (push, hold rotate the knob, etc.). I haven’t tried yet accessing the machine through the IDE interface (loading the old or any firmware through it) but having the computer NOT seeing the printer, I doubt that IDE will be able to connect to it anyway. Obviously, I checked the cable (tested it). It WAS working before the update anyways.

So sorry, we all have had it happen. I’m in the middle of a cluster my self…