.env ignored - no supported firmware detected - Win10

LaserWeb information

LaserWeb 4.0.998

Problem description

I am trying to use LaserWeb4 for my first time but receive the No supported firmware detected message when trying to connect. I’ve been through other support items and it’s clear my board is not supplying the proper version of firmware as LW4 would expect. I have tried using the RESET_ON_CONNECT=1 in the .env file but it did not change the behavior. I then added LOG_LEVEL=3 to the .env file. This also did not change behavior or create the log file. It appears the .env file is being ignored on my Windows 10 machine.

Each time I tried this I shut down and restarted LW4.
I first tried this procedure in *C:\Users\username\AppData\Local\Programs\lw.comm-server*
I also tried the .env procedures in another lw.comm-server folder I found located at *C:\Users\username\AppData\Roaming\lw.comm-server*
Neither location worked.

PuTTY gives this when pressing ctrl-x
Ortur Laser Master 2 Ready!
OLF 137.

Grbl 1.1f [’$’ for help]

System description

  • My machine is a ORTUR LaserMaster 2 diode laser run by the STM32 MCU running Grbl 1.1

  • I connect via USB | Serial, COM3, 115200

  • My computer(s) on which I run LaserWeb is Windows 10 Pro build 19041.450

Here is my configuration:


The status messages tell me that the board was not sending any messages, otherwise you would see the messages in the terminal area. Are you sure that COM3 is the correct port?

The “.env” file has to be place at the location where the exe is. Check the properties of the LaserWeb desktop icon to see where this is. And you should check that the env file is named correctly: only “.env” with nothing before the dot or after the env!!! You may need to change the windows settings to show file extensions of known file type. By default, windows hides endings like “.txt”, so you ony see “.env” when the filename is “.env.txt”.

By the way: With RESET_ON_CONNECT=1 LaserWeb sends a ctrl-x to the board right after connecting. If that doesn’t work, it might help to disconnect and reconnect the USB right after clicking connect in LaserWeb.

The problem also might me caused by the changes that Ortur did when porting grbl to STM32, but I would need such a controller board the test that.

1 Like

Hi cprezzi!
Thank you for the quick reply!!! Are there any other reasons you think the .env might not be used by LaserWeb.exe?

When connecting with PuTTY using the same port(COM3) and baud rate(115200) I can connect, send ctrl-x and receive the GRBL 1.1 response from the ORTUR. I think my problem is I’m not able to get LaserWeb to recognize the the .env file to force the ctrl-x command.

Following the many other posts I’ve tried these items:

  • Validate the “.” is in front of the .env file
  • I have enabled File Extensions to confirm nothing follows .env like “.env.txt”
  • Executed the .bat file that automatically creates the .env file with the appropriate command.
  • manually created text file called env.env. Then from the command line I ran ren env.env .env which from everything i can tell properly renamed it.
  • uninstalled and reinstalled LaserWeb. Also tried both x86 and 64 packages.

To validate my files here are the two paths: Anywhere my user name is referenced I replaced it with %username% to protect the innocent. :slight_smile:
.env file:
Desktop shortcut target:

Below are screen shots. Note .env changed to look like a text file after I told Windows 10 to always open this .env in notepad.

Below is the command prompt with all the files in that directory. To be sure I’m running from the same directory I ran C:\Users\%username%\AppData\Local\Programs\lw.comm-server>LaserWeb.exe
Note .env appears to be properly named.

 Volume in drive C is Local Disk
 Volume Serial Number is 42CF-7BBD

 Directory of C:\Users\%username%\AppData\Local\Programs\lw.comm-server

09/07/2020  08:13 AM    <DIR>          .
09/07/2020  08:13 AM    <DIR>          ..
09/07/2020  08:17 AM                50 .env
09/28/2017  03:31 PM            18,744 api-ms-win-core-console-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-datetime-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-debug-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-errorhandling-l1-1-0.dll
09/28/2017  03:31 PM            21,816 api-ms-win-core-file-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-file-l1-2-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-file-l2-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-handle-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-heap-l1-1-0.dll
09/28/2017  03:31 PM            17,856 api-ms-win-core-interlocked-l1-1-0.dll
09/28/2017  03:31 PM            18,744 api-ms-win-core-libraryloader-l1-1-0.dll
09/28/2017  03:31 PM            20,792 api-ms-win-core-localization-l1-2-0.dll
09/28/2017  03:31 PM            18,744 api-ms-win-core-memory-l1-1-0.dll
09/28/2017  03:31 PM            18,232 api-ms-win-core-namedpipe-l1-1-0.dll
09/28/2017  03:31 PM            19,248 api-ms-win-core-processenvironment-l1-1-0.dll
09/28/2017  03:29 PM            19,392 api-ms-win-core-processthreads-l1-1-0.dll
09/28/2017  03:29 PM            18,744 api-ms-win-core-processthreads-l1-1-1.dll
09/28/2017  03:29 PM            17,712 api-ms-win-core-profile-l1-1-0.dll
09/28/2017  03:29 PM            17,720 api-ms-win-core-rtlsupport-l1-1-0.dll
09/28/2017  03:29 PM            18,232 api-ms-win-core-string-l1-1-0.dll
09/28/2017  03:29 PM            20,280 api-ms-win-core-synch-l1-1-0.dll
09/28/2017  03:29 PM            18,744 api-ms-win-core-synch-l1-2-0.dll
09/28/2017  03:29 PM            19,248 api-ms-win-core-sysinfo-l1-1-0.dll
09/28/2017  03:29 PM            18,224 api-ms-win-core-timezone-l1-1-0.dll
09/28/2017  03:29 PM            18,232 api-ms-win-core-util-l1-1-0.dll
09/28/2017  03:29 PM            19,256 api-ms-win-crt-conio-l1-1-0.dll
09/28/2017  03:29 PM            22,328 api-ms-win-crt-convert-l1-1-0.dll
09/28/2017  03:29 PM            18,736 api-ms-win-crt-environment-l1-1-0.dll
09/28/2017  03:29 PM            20,280 api-ms-win-crt-filesystem-l1-1-0.dll
09/28/2017  03:29 PM            19,256 api-ms-win-crt-heap-l1-1-0.dll
09/28/2017  03:29 PM            18,744 api-ms-win-crt-locale-l1-1-0.dll
09/28/2017  03:29 PM            28,984 api-ms-win-crt-math-l1-1-0.dll
09/28/2017  03:29 PM            26,424 api-ms-win-crt-multibyte-l1-1-0.dll
09/28/2017  03:29 PM            73,016 api-ms-win-crt-private-l1-1-0.dll
09/28/2017  03:29 PM            19,256 api-ms-win-crt-process-l1-1-0.dll
09/28/2017  03:29 PM            22,840 api-ms-win-crt-runtime-l1-1-0.dll
09/28/2017  03:29 PM            24,368 api-ms-win-crt-stdio-l1-1-0.dll
09/28/2017  03:29 PM            23,488 api-ms-win-crt-string-l1-1-0.dll
09/28/2017  03:29 PM            20,792 api-ms-win-crt-time-l1-1-0.dll
09/28/2017  03:29 PM            18,744 api-ms-win-crt-utility-l1-1-0.dll
08/22/2018  12:52 PM            25,856 blink_image_resources_200_percent.pak
08/22/2018  12:52 PM                15 content_resources_200_percent.pak
08/22/2018  12:52 PM        10,266,133 content_shell.pak
08/22/2018  12:58 PM         3,466,856 d3dcompiler_47.dll
08/22/2018  12:52 PM         1,695,232 ffmpeg.dll
08/22/2018  12:52 PM        10,130,560 icudtl.dat
04/25/2020  07:28 AM        49,901,056 LaserWeb.exe
08/22/2018  12:53 PM            15,872 libEGL.dll
08/22/2018  12:53 PM         2,543,616 libGLESv2.dll
08/22/2018  12:48 PM             1,060 LICENSE.electron.txt
08/22/2018  12:51 PM         1,783,609 LICENSES.chromium.html
04/25/2020  07:28 AM    <DIR>          locales
08/22/2018  01:18 PM           440,120 msvcp140.dll
08/22/2018  12:53 PM           239,010 natives_blob.bin
08/22/2018  01:03 PM        14,177,792 node.dll
08/22/2018  12:59 PM           140,979 pdf_viewer_resources.pak
04/25/2020  07:28 AM    <DIR>          resources
08/22/2018  12:54 PM         1,177,052 snapshot_blob.bin
09/28/2017  03:29 PM         1,142,072 ucrtbase.dll
08/22/2018  12:54 PM            76,195 ui_resources_200_percent.pak
04/25/2020  07:29 AM           132,759 Uninstall LaserWeb.exe
08/22/2018  01:18 PM            83,784 vcruntime140.dll
08/22/2018  12:55 PM            57,450 views_resources_200_percent.pak
              62 File(s)     98,341,968 bytes

Can you please show the content of the .env file?

I tried a couple different things. Below are examples. No other characters were in the file except for line breaks and what I have below.


then just logging to see if I would get a log file. No log file created.

Then I put a few things together.

Zip file with .env files.

Cprezzi, any chance I could try the bits you complied for another individual to force the reset? Curious if I can even get the Ortur to work with LW4. In the meantime I’m setting up a separate machine with Windows 10 home edition. I’m curious if something like Windows defender ATP is stopping the solution from seeing the EnV file. Assuming I have the file properly formatted.
I’m running on a Windows 10 pro now.

Hmmm. I tried on a fresh clean default settings Windows 10 Home install on a new laptop with the .env file set to LOG_LEVEL=1 and no log file is created. Either I am miss formatting the env file or the solution for some reason will not pick it up. I believe that should create a log file in the same directory as the LaserWeb.exe file. Correct?

I believe there may be an issue with the latest version of LaserWeb. I uninstalled the latest version of Laser Web and went back to version 4.0.991 and I was able to make the Ortur work with LaserWeb. It appears that in 4.0.998 the .env file is ignored on Windows 10. However, in 4.0.991 I’m able to create a log file and connect to my printer with the same Windows 10 machine.
This is the link I used for the older version of LaserWeb.Setup.4.0.130.exe. https://github-production-release-asset-2e65be.s3.amazonaws.com/89124008/13974850-4fe2-11e8-8b80-ea688d8817aa?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200913%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20200913T193711Z&X-Amz-Expires=300&X-Amz-Signature=7d0e75c466063dc505a8eb49c9a3005ec8fb92d7b49d889ef54f9c2e6b12570a&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=89124008&response-content-disposition=attachment%3B%20filename%3DLaserWeb.Setup.4.0.130.exe&response-content-type=application%2Foctet-stream

Thank you,


Thank you for this info. I will try this on my system.

I found a workaround! You can set a environment variable globaly in Windows.

  • open the startmenu
  • type sysdm.cpl [enter]
  • select extended tab
  • click “Environment Variables” button
  • click “add” and enter “RESET_ON_CONNECT” as variable and “1” as value

(you can also add a variable “LOG_LEVEL” with a value of 1, 2 or 3 to get a logfile.)


IT WORKED!!! Thank you!!! Looking forward to diving in and seeing what I can do. Only thing I’ve tried so far is jogging the laser but WOOT WOOT… I’m in…
Thanks Claudio!!!

1 Like

You are welcome!