Don't start Z-Probe Smoothieboard with BLTouch

My Name is Meik and I hope you can help me.
I use a Smoothieboard 5XC with BLTouch.
If I will start the Probe leveling-strategy.rectangular-grid the x,y,z turn to min. Position.
The Z-Probe to not start the probeding.
The Probe Offeset between the nozel and the BLTouch is 4,1mm.
I think I have a bug in the config…
Thanks for the help

I start the Prozess with:

M280 S3.24

I use the actual firmeware.
Here is my config:

switch.bltouch.enable                    true         #
switch.bltouch.output_pin                1.23         # sw pwm can use any digital pin
switch.bltouch.input_on_command          M280         #
switch.bltouch.input_off_command         M281         #
switch.bltouch.output_type               swpwm        # sw pwm must be low frequency
switch.bltouch.pwm_period_ms             20           # 50Hz
switch.bltouch.startup_state             false        # start up in the stow state
switch.bltouch.startup_value             7.43         # On boot it will go into stow mode, also set with the M281
switch.bltouch.default_on_value          3.3          # if M280 is issued without S this is the value it will set it to

# Z-probe
# See

gamma_min_endstop            nc                 # normally 1.28. Change to nc to prevent conflict, not needed on Azteeg X5
zprobe.enable                true               # set to true to enable a zprobe
zprobe.probe_pin             1.28^              # pin probe is attached to if NC remove the !, Azteeg X5 this is 1.29
zprobe.slow_feedrate         5                  # mm/sec probe feed rate
#zprobe.debounce_ms          1                  # set if noisy
zprobe.fast_feedrate         50                 # move feedrate
zprobe.probe_height          5                  # how much above bed to start probe NB only needed for G32 on delta
zprobe.return_feedrate       0                  # feedrate after a probe, default 0 is double of slow_feedrate (mm/s)
zprobe.max_z                 555.3              # maximum default travel for the probe command, will use gamma_max if not defined

# Levelling strategy
leveling-strategy.rectangular-grid.enable               true      # The strategy must be enabled in the config, as well as the zprobe module.
leveling-strategy.rectangular-grid.x_size               460       # size of bed in the X axis
leveling-strategy.rectangular-grid.y_size               470       # size of bed in the Y axis
leveling-strategy.rectangular-grid.size                 7 	      # The size of the grid, for example, 7 causes a 7x7 grid with 49 points. 
                                                                  # Must be an odd number.
leveling-strategy.rectangular-grid.do_home              true              
leveling-strategy.rectangular-grid.probe_offsets        21,53,4.1 # Optional probe offsets x,y,z, from the nozzle or tool head                 true      # If the saved grid is to be loaded on boot then this must be set to true
leveling-strategy.rectangular-grid.initial_height       10        # will move to Z10 before the first probe
mm_per_line_segment                                     1         # necessary for cartesians using rectangular-grid
leveling-strategy.rectangular-grid.before_probe_gcode   M280      # uncomment if you have a bltouch
leveling-strategy.rectangular-grid.after_probe_gcode    M281      # uncomment if you have a bltouch