Cnc. Ramps grbl mega-5x and grblgru arc lagging


I have a problem with my cnc. the controller is a ramps board with grbl mega-5X and the software is grblgru.

When i run a program with an arc it is lagging. a normal rectangle no problem. but if there is a small arc in the corner. it runs the strait line fine. but the corner it have a lot of small pauses.

I have asked the question in another forum. where the solution was to use other software to generate the code. they said that grblgru is making a lot of small lines in an arc. and other dont.

i tried to use solidworks and run a program. then the problem is solved.

i just really likes the grblgru software. so i really want it to function. and it don’t lookes like other having same problems… can it be some settings in the grbl firmware or?

@GrblGru do you maybe have a hint?

Best regards Danni.

First of all, thank you for your feedback. I am always grateful when someone reports a problem to me. Because only in this way I can eliminate errors. :slight_smile:

But now to the problem with the arcs.
When I read in a DXF or SVG file, I convert all the individual geometric objects (straight lines, circles, arcs, etc) of a path into a polygon curve.
This consists only of small straight line segments. This is done because ramps and tabs have to be built into the path in the further course. Also the tool radius compensation needs a cluster of points.

You can display the size of the segments. Select the path and choose “Show / Hide points” in the right mouse context menu.
If the default settings are not ok for your application, you can change the number of points in the settings with the parameters “Accuracy 2D” and “Polyline cleaning”. “Accuracy 2D” indicates the maximum allowed deviation from the original curve. The smaller the value, the more points are generated.
Changes to the values will only take effect when reloading.

Please download the new beta version V4.2.21. I have extended the setting range in it.
Please let me know if you have any questions or if something doesn’t work.

1 Like