Chillipeppr Grbl Autolevel a.k.a bit snapper 5000

Hey there knowledgable people. Does anyone know why the chillipeppr auto level is driving by bits into the material at full speed snapping them off every time?

I have my probe wiring to connected to the A5 pin on the Grbl1.1f board.

In CNCjs, if I run the probe command, it lowers the z axis until it makes contact and the raises. The expected result.

In Chillipeppr, if I ‘Run Test Probe’ , the Z axis lowers until it makes contact, then stops. The expected result.

In Chillipepper, If I now lift the z axis up a couple of mm back off the board, then execute the Autolevel, the z axis just goes full pelt into the board, snapping the bit. I don’t know how many more bits a can sacrifice testing this.

Any ideas?

I am having some mixed results after getting a few successful boards. So your auto leveling? what are you cutting?

Are you cutting a PCB or something conductive? and using a contact mechanism to check when it touches the surface?

Yes a PCB, one probe wire to bit, the other to the pcb.

The wiring is working obviously as the test probe works in other software.
The ‘Run Test Probe’ command in Chillipeppr also works as expected and stops when contact is made.
Its only when the actual auto level script is run that things go awry.

Gotcha, I can explain my process. I now have it fully repeatable.

  1. Probe to the surface (Or get manually close, need to be within -0.5mm for default settings)
  2. Zero Workspace
  3. Run Auto Level (with #1, default settings should be fine)
  4. ***DON’T zero again, even though the board coordinates look like the zero was reset
  5. Send GCODE to Workspace
  6. Send Level Data to Workspace
  7. Run

****If you happen to soft restart and your using (grbl 1.1, not sure on others), its best to just refresh your browser. Otherwise, Z and other parameters can act funny afterward, unpredictably.

If you have multiple stops and failures, its sometimes gets out of wack, and only way to recover is to refresh the page, and resetup any settings you have changed

“The wiring is working obviously” - I was assuming so, but then again, I try to not assume anything (just never know).

1 Like

Ok I followed your instructions and it works!
I was missing step 2 and didn’t realise zeroing the workspace was necessary after probing once. It seems a little counter intuitive to me to have to tell the probe where to start from. The whole idea of probing is to detect and set z stuff automagically. I would have expected it to work like Marlin mesh bed levelling or Candle.
Anyways, at least thats cleared it up so thanks!

Seems unnecessarily painfully slow though. It should be updated to follow better examples with a fast course probe followed by a slow fine one to speed the whole process up.

I totally agree. I discovered it via trial and error. I originally thought zeroing was the way to do it at the start and all would be ok. I saw the coordinates change after auto leveling, i zeroed again, and it went way out in left field. So, yeah. Trial and error, this shouldn’t be this way, but it works for now.

Glad I could help

1 Like

Actually I realised the boards a generally quite flat anyway. The resulting probe data doesn’t deviate more than 0.01mm for me so the Autofill values are far too high. By tightening all the parameters, the Autolevel can be much faster.

1 Like

Nice. I get the occasional, went through all the steps and then it tries to cut above my copper. I then have to restart the page and set everything back up again. Seems to happen after soft resets. Which I might be stopping incorrectly and causing other issues.

Anyway, happy cutting.