Can't make a hole drill it will only mill (GRBL)

I’ve been using Chilipeppr for a while now and as long as I clear my cache, I generally don’t have problems. However, today have a board with single jumper pins (Eagle library). I can’t adjust the setting so that the holes for the pins are drilled. I’ve set the max size hole to be drilled to a huge 5mm, turned off dimension milling. All this does is skip the holes altogether, I can only get the hole if I switch on dimension and set hole and mill size the same, but I then don’t get a chance to change tool for the outside dimension. (should I use tool set by wire width?)

Oh boy, it’s hard to totally know what you mean. Would it be possible to post a screenshot of your Eagle conversion settings and a screenshot of how it’s interpreting it into the 3D viewer?

I have since thrown it away, but I have examined the Eagle component and found a small square of pale blue on top of the hole. The blue square was a patch of layer 46 “milling”. I don’t really understand this but I deleted it and the odd behaviour stopped.


1 Like