Anybody ever tried an Arduino Nano?

gplus
(Leo Bettinelli) #1

Anybody ever tried an Arduino Nano?

I am facing this little strange behaviour that would really like to understand!
http://forum.arduino.cc/index.php?topic=336694.new#new

(Daniel Garcia) #2

It sounds like this got flashed with something similar to the trinket bootloader which, when it starts up, spends 5-10s “listening” for a firmware update and if one doesn’t start then it drops back into normal running. (I don’t know if this is actually something the nano’s bootloader wants to do normally)

(Kenneth Tan) #3

Yes, it must be the bootloader. Different arduino’s different wait-time.
You could flash a “no-wait” bootloader into the arduino. that would solve this “by design” behaviour.

(Mike Thornbury) #4

It’s not the way my Nano’s work. Where did you get your board?

(Daniel Garcia) #5

@Mike_Thornbury it s possible to program a new bootloader easily enough. I’ve definitely put the wrong bootloader on before.

(Leo Bettinelli) #6

thanks guy for participating!

My nano is a clone.

Could somebody guide me in the process of modifying the bootloader? I´ve never done such thing.

Thanks!

(Mike Thornbury) #7

https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader

(Kenneth Tan) #8

Try the optiboot Bootloader.
https://code.google.com/p/optiboot/
With this bootloader, it wil skip the wait for a sketch upload and immediately execute the internal sketch.
Only when the reset button is pressed iet will go into “wait” bootloader mode. With power cycle it will return to no-wait.
It should work on all atmel 328, so also cheap chinese clones of arduino nano pro.

if your arduino has a an avr pinout (http://obd2.tui21.com/img/minibox/arduino-nano-v3.0-avr-atmega328-p-20au-board20134361.jpg) then you could flash the bootloader with a cheap (chinese :wink: ) avr usb adapter.
http://www.ebay.nl/itm/351452782591?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT

If your Arduino clone has no ICSP connector or pinout, read the link from the reply above or look at this link:

(Leo Bettinelli) #9

great guys. thank you so much!