4 solid green LEDs and 1 orange

smoothie-forum
(moriartynz_SW) #1

Hi all,

I have just unboxed my brand new Smoothieboard 5XC from Robotseed and plugged it into my laptop’s USB port. I get 4 green LEDs (solid) and 1 orange LED. From the Troubleshooting page, I was told that this means:
Firmware didn’t get flashed, you need to flash it and also make sure you uploaded a valid config.

I downloaded a new config file from githib (linked on the smoothieware.org site) and a new firmware.bin from the website (new user so cannot post links), plugged the microsd from Smoothieboard directly into the computer and replaced the config and firmware.bin file on the microsd card. I checked the card for errors (there were none), safely ejected and plugged the microsd back into the Smoothieboard. Powered it back up and got the same result (4 green solid LEDs and 1 orange LED).

How can I get the firmware to flash on the board please? Many thanks.

Regards
Mark

Imported from wikidot

(moriartynz_SW) #2

Interestingly, if I unplug the microSD, I get green LEDs 1 (solid), 2 and 3 flashing and 4 off (since no SD card) and orange LED. The trouble is I need to have a new config file so while the board is clearly flashed, it does not seem to be updatable.

I also get an error when trying to install the Smoothieboard USB Serial driver (v.1.0 as I have Win 8.1): “A service installation section of this INF is invalid.” Not sure if that is related.

(Arthur Wolf) #3

Can you try formating the SD card, and starting back with fresh files off the website, and if that doesn’t work, find a sd card around, format it, paste the files, and start with that ?

(moriartynz_SW) #4

Thanks for the reply arthurwolf. I have located another microSD card knocking about and used that. What I did was:

  1. formatted the card as FAT32 (URL not permitted so reformatted here with spaces) http :// instruform.com /images/20150907SDProperties.png
  2. Downloaded the firmware file from http :// triffid-hunter.no-ip.info /Smoothie-edge.bin
  3. Downloaded the delta config file from https :// github.com /Smoothieware/Smoothieware/blob/edge/ConfigSamples/Smoothieboard.delta/config
  4. Copied these to the newly formatted microSD card and renamed appropriately:
  5. http :// instruform.com /images/20150907SmoothieFiles.png
  6. Safely ejected the microSD card
  7. inserted the microSD card into the Smoothieboard
  8. Applied 5V power from USB port
  9. Result is 4 green LEDs and 1 orange LED as before

Any idea how to resolve this?

Many thanks.

(Arthur Wolf) #5

Hey.

Can you pack the sd card’s content into a .zip file, and email them at wolf.arthur@gmail.com ?

Cheers.

(moriartynz_SW) #6

Hi Arthur,

Thanks for the reply. As requested, I have zipped the SD card’s contents and sent them to your email. Thanks for any insights.

Regards
Mark

(Arthur Wolf) #7

Got the files, thanks.

Everything looks ok there.

Can you tell me what happens if you boot the board, with the config file deleted ?

(moriartynz_SW) #8

Wow! That was a speedy reply Arthur. Thanks.

Deleting the config file and safely ejecting, inserting MicroSD into the board and powering gives 4xsolid green and 1 solid orange. Even if I delete everything (config and firmware) from the microSD card, I get the same result.

(Arthur Wolf) #9

Do you have IPA or some sort of cleaning alcohol ? If so could you try cleaning the SD card slot with that, and a piece of paper ?

(moriartynz_SW) #10

I have now sprayed it with isopropyl alcohol and used tissue paper to dab the terminals of the microsd slot. Unfortunately, I get the same result (4 solid green, 1 solid orange).

(Arthur Wolf) #11

Did you get the board from RobotSeed or Uberclock ?

(moriartynz_SW) #12

I got the board from Robotseed.

(Arthur Wolf) #13

You can contact RobotSeed support, ask for a replacement board, and tell them Arthur validated it.

Really sorry for the bad board, we fully test them before shipping and would have noticed this, not sure what’s going on here.

(moriartynz_SW) #14

Thanks for the apology, Arthur. Sometimes testing does not always detect all of the issues all of the time.