Y AXIS STEPPER TORQUE

smoothie-forum
(Mert G) #1

Hello,

i`ve build a 3d printer which is a Cartesian style machine. i`m driving all my axis via ball screws. I was using NEMA 17 steepers with 2.0Amp rated in all axis and to get a better torque i`ve upgraded them to NEMA 23 1.5Amp motors which has bigger holding torque compare to Nema 17 ones. Anyway I had problems with steppers because of accelerations etc. and i`ve reduced down the acceleration value and other things. But i`ve still problems on Y axis. So i tried to stop my ball screw by my bare hands when they are rotating and it was so easy to stop Y axis. X axis is strong enough but Y is acting as it is driven with very low torque. So do anyone can give an idea what might happened? I hope there is no problem with my board!

i`ll try to put my Nema 17 motor back to compare it but i`m worried a bit.

Also i`m have question in my mind about setting up Acceleration for my ball screws. i`m using 16-10mm ballscrews. which should be quite ok. but i have to reduce my acceleration to 100mm to be able to drive them with 23hs221504s 1.16Nm NEMA 23 motors
if someone can give me sort of explanation about this matter it would be great.

Imported from wikidot

(Arthur Wolf) #2

This can happen if there is a problem with wiring or connectors, and only 3 out of 4 stepper motor wires actually connect with the board. I’d check the crimps and wires, and also try using another stepper motor on that stepper motor driver.

(Mert G) #3

Hi Arthur,
Thanks for the reply. it was my fault i forgot to tighten the screw on coupler!!!
so its better now. But i ahve another important problem now.
i can drive my Y axis (16-10 mm ballscrew) over 2000mm/min. I have same config on X axis (16-10mm ballscrew) and i can drive it up to 7000mm/min. with G1 F7000 command. x axis stucks at F8000 which is ok for me. But i can`t understand the main issue with Y Axis. i`was worried about the shaft alignment as i have flexible coupler it should compensate but even though i tried to make it straight. but it didn`t help either. My config is below if you have any ideas please let me know. Fianlly i thougt about mechanical issues caused by ballscrew s nut. I`m not sure but Nut on Y axis has bigger play than X axis. May be it is normal but i`m thinking it might be causing trouble. is it possible?

default_feed_rate 1250 # Default rate ( mm/minute ) for G1/G2/G3 moves
default_seek_rate 1250 # Default rate ( mm/minute ) for G0 moves
mm_per_arc_segment 0.5

alpha_steps_per_mm 320
beta_steps_per_mm 320

planner_queue_size 32
acceleration 80

acceleration_ticks_per_second 1000
junction_deviation 0.05

#z_junction_deviation 0.0

microseconds_per_step_pulse 1 # Duration of step pulses to stepper drivers, in microseconds
base_stepping_frequency 100000 # Base frequency for stepping

x_axis_max_speed 2000 # mm/min
y_axis_max_speed 2500 # mm/min

alpha_max_rate 2000.0 # mm/min
beta_max_rate 2000.0 # mm/min

(Arthur Wolf) #4

Hey. This is probably being caused either by the Y axis being heavier, or simply an alignment/mechanical problem.

(Mert G) #5

my Y axis is so lighter than X Axis.
i think its the only option, it is probably realted alignment issues. I will try to fix it. Hope i can.