X axis issue - only moves left, won't home

When I power it up the Y axis will move to home with no issue, however when the laser head moves to its home position, it just keeps on wanting to move left, despite the limit switch operating. See attached video.

I have disabled home on the x axis using the keypad on the machine and on startup the Y axis homes as it should and the axis is then stationary, when I then try to manually move the X axis via the keypad, it will only move to the left even, if I press the right button on the keypad.

It will keep on trying to move left despite the limit switch operating (it registers accurately on the keypad when I do diagnostics on the key pad.)

I’ve tried looking at the machine settings and playing with these to no avail.

Any help gratefully recieved, thanks!



What kind of K40 as am not familiar with one that allows you to read the limit switches.

Usually, this kind of problem is caused by a limit switch inop [but you say its ok].
On standard K40 the optical switch can be damaged by the flag or the flag is misaligned.

I would check the limit switch and all the wiring for the limit switch carefully.

Post a picture of the control panel and the limit switch you refer to.

1 Like

Hi Don,

Thanks for the speedy reply!

It’s not actually a K40 it’s a 50watt I bought from Vevor in the UK.
The pictures below show the optical switch off when the head isn’t at the end of the axis and on (lit) when the head reaches the end.

The others two pictures show the diagnostic menu on the control panel (access via U/Z, then diagnostics) where you should see the X limit flag in red when the switch is operated (lot), and greyed when it is not lit, if that makes sense?


Ah, it’s not a stock K40 controller.
I have not used that machine or controller.

  • Did this ever work?
  • Have you contacted the seller?

The symptoms seem to match a bad X limit function but it sure looks like it is working.

I would look for ways the diag could be fooling you into believing it works.

Can you provide the controller’s model or alternately a link to the manual so we can take a look at the settings?

Is there a setting that ignores the limit switches?

It’s an RDC644XG controller Don

I’ve contacted the supplier for support, but they’re very vague in their responses.
They say it’s a key reversal and asked me to check key parameters.

I’m not really sure what exactly they’re referring to, whether it’s in Rdworks or on the machine control panel

I’ve looked in both and can’t see anything wrong! :pensive:

Sounds like a hardware failure.

Check in the electronics cabinet to ensure your X motor driver doesn’t have an error indicator illuminated on the hardware. Each driver has a red led below the green… The red led option is a poor choice. :crazy_face:

The controller is ‘seeing’ the X home switch, indicated by the diagnostic screen, it’s next step is to ‘back off’ the switch.

Going only one way (homing and control panel) indicates to me it’s probably not getting a proper direction signal from the controller or the motor driver has failed.

I’d check the ‘direction’ signal from the controller to the motor driver.

Doubtful the stepper motor has a problem.

Most of these are motor drivers are wired identically, so you could double check the wiring to ensure they are the same, and probably just swap the other motor driver to the Y axes to test the motor driver… If you are confident in your abilities and understand this, it is the most simple.

If you look at my photo, the single left connector is all you need to move to the other motor driver board. It’s one connector. The Y motor will respond but if you can move it from the machine console both directions it will indicate a bad driver.

Hopefully you know you can press ‘esc’ and abort the home sequence… ?

Make sense?


1 Like

Thanks Jack,

I’ll have a look at this this afternoon.


Fixed it, it was a loose connector on the motor driver (red wire) connector block, it just popped out when I went to swap the x and y controllers as per Jack’s suggestion!

Thanks for the help Jack and Don, very much appreciated!