Web interface

After much research and trial and error I have finally gotten my smoothie board installed and firmware configured. I can connect via usb and print files just fine. This gives me really nice quality prints. Now I went to enable the networking and set a static ip address. When I enter the ip address in my browser, I get what looks like pronterface. I can read temps, make the printer motors move and operate the heaters. I can upload a file just fine and it reports file uploaded successfully. But it won’t print. I don’t know why. There were no error messages. Where do I look to fix this?

Imported from wikidot

I must have had the cone of silence on for this one. Nobody apparently hear me.

Did you click refresh next to printable file list?

Yes. And then the file disappeared. It’s still on the sd card as I can see it in file manager on my computer.
I wonder if it would be possible to port the Duet Web Control to a Smoothieboard? I might have to go learn how to write code.

Well, I updated the web interface according to what I found in the documentation. The web interface still does not work. Now the file shows up as available to print, but when I click print, everything freezes up. I have to power cycle everything to get it to operate again.

So. Is this such a common problem and nobody has fixed it? Just curious. Since a format and reinstall of firmware and all other files has not solved it. I’m beginning to think that I made a poor buying choice.

Going to list this board on Ebay. It apparently works like it is supposed to, but I can’t get the web interface to work. I just purchased a Duet Ethernet to replace it. I know their web interface works.

Web interface works for thousands of users. I’ve seen problems like yours before ( though not in a long time ) and they had to do with specificities of the local network ( partial internet access, or some weird router things ).

Can you try on another network ? In another browser ? Can you try formatting your SD card ?

Only one network to hook up to. Tried formatting the sd card. Tried Chrome and Firefox. You can’t pay me enough to open any web browser from Microsoft. I can open the web interface. I can home the printer. I can move all axis’ via the control buttons. I can turn on and off the heat bed and hot end heaters. I can turn the parts cooling fan on and off. It all works. Until I try to print a file. Doesn’t matter what file I try. It just freezes up. Nothing heats up, nothing moves. I have to power cycle the machine to get it to respond again. I can print a file just fine via usb from Simplify3d.

I bought this Smoothie board before I found out the short coming of the web interface. From what I’ve read, you can’t close the web browser once a file is started. You can’t access it from a different computer on the network once a file is started to be able to monitor it. What’s the point?

On my Duetwifi I have, once a print is started, it is on the sd card and the Duet takes over from there. You can shut that computer completely off and access the web control fro a different computer without causing problems for the print.

My new Duet Ethernet is scheduled to arrive on Monday. I will swap it for the Smoothie board and then sell it at a loss on ebay with full disclosure that I was not successful in getting the web interface to fully work.