Vigotec VX-L7

Hi All,

Yes another Chinese stuff. It worked fine the first time. I mean, it turned on.

Couple of simple engraving tests. Fine.

Tried cutting plywood. No chance. Just burning the surface. Tried several rounds. Just burning the wood.

Decided on cutting plywood, I took the laser unit out. Put it on my cnc-converted 3d printer. That is, I replaced the printing head with the laser unit. 3d printer controls the XY and the Z movements, I manually turn ON-OFF the laser.

With the Z control, I can adjust the focal depth at each round, so that I can go deeper (0.8mm) into the plywood; and the result: at 5 rounds with 100% power and 500 mm/min speed I can cut 4mm plywood nicely and cleanly without buring the wood.

Nice but of course not a practicle enviroment fow working.

First, there are lots of details in the cutting (ie holes) which I can not cope with manually.
Second, printing area for the laser engraver is larger. I prefer to work there.

I added a simple Focus Control system to the laser unit using an Arduino Nano with 28BYJ stepper motor. Simple frictional rotation employed on the lens frame. Mecjanically works fine.
Time to test it on the machine.

Oops, we got a problem.

Can not start the system at all. Long press does not work.
The fan starts. Red LED is on. No Blue led, no nothing. no start.

I tried testing each cable one by one. With Long Press (or short or double, triple…)

  • 12v ground out: nothing works
  • 12v + out: nothing works
  • 5V ground out: fan works. Red LED on. Nothing else
  • 5V + out:::::: Laser Turns on at full power. But the system does not start.

Could not interpret all this.

any idea??

I looked into the driver board built in on the laser module. For the four input pins it says:


T stands for TTL I believe.

First three cables go together into a plug, and the fourth (the T) goes to another one as a single cable.

I tried controlling the module by connecting +5V to PWM pin, and GND to T from various sources: From an outside 5V DC adapter with or without common ground with 12V+ (VCC), or Arduino Nano +5V and GND, but did not work ( It did in the very early first tests I mentioned in my previous message).

I measured the voltage between PWM and T: -2.3 V. Yes, MINUS 2.3 V. Tried several times. Yes, correct. MINUS.

So the I tried inputting negative volts. ie, connect ground to PWM and +5V to T. And it works. I mean it controls the laser module. In a negative way of course. If the voltage is on, no laser beam. If off laser lights up.

So, somehow the logic on the board was reversed?! And combined with 2.5V but not 5V, can we say that the AC/DC converter is faulty on the board? Positive half gone?

Actually maybe not gone, but kind of not working properly. During my tests for a very brief period of time, the control board was UP and running; not perfectly but running ok.

I was even able to connect via wifi, run gcode; but noticed the link was going down very frequently., and eventually died off again. I could not visually determine which part is defective, but I believe there is one culprit causing all this trouble.

I don’t have this machine and could not find info on this model number anywhere.
Here are some guesses that may or may not be helpful…

Posting pictures of your setup may help.

  • Close up of all circuit cards
  • Close up of the wiring you are referring to

Post link to where you got the machine
Post pictures of the marking on the laser head

Do you have any specs on the laser head?

Also, try searching this forum as there have been multiple posts on this type of machine.

First of all, thanks for your detailed answer with recommendations.

I will try to answer your questions one by one, try to explain what I have done or wanted to do, and some pictures as much as possible.

During these final tests, the system came up several times. I was able to connect via wifi. Start weak beam. But could not start the full power. System could not last that long. One of the parts gets very hot on the control board. System givses some alarm beeps and shuts down or gets lost.

The part excessively heating is the one on top right; left of two capacitors, marked U2 or V2.

Uploading: vigoLaserInside.jpg… Uploading: VigoLaserControlBoard.jpg…

If a capacitor is heating up that is another sign of a power problem, usually an overvoltage, reversal or AC on the cap. Measure the voltage across the capacitor, looks like it should be + 5V.

Perhaps your 5V on the card is blown?

T for TEMP!

Following your suggestion I wanted to measure the voltage on the card for the fourth line, and noticed that the plug was labeled as TEMP.

So, all my previous assumptions were wrong. No ground, no TTL. Not even input.

Anyway, I measured it, and it was changing. First it was -1.66. Later it twent up to + 2.3. That is when the system halts itself, due to high temperature.

Voltage across the capacitors are +3.2. and voltage across the U2 unit (not the capacitor, next to it) at its three legs are +3.2, 0.0, -2.3.

Somehow we don’t see a clear +5V, but more or less the half of it. Somehow the +5V is damaged at least.

The system comes up every now and then. The processor ( on the far right, big metal square) heats up as well. I added a huge heat sink (of the 3d printer’s extruder’s sink). It takes a bit longer, but then the system shuts down, or freeze.Not much of a hope on this card.

I have started planning on moving onto my cnc.

You can unplug the temperature connection and see if the controller still shuts down. Is the laser head electronics hot also?

However the more you run the controller with a power problem [if it has one] the more likely you will do irreversible damage. That said you may have to power it up to find the problem :frowning:

I would find the 3.3V [most likely] or alternately 5V power regulator and find out what the chip is and how it is wired in.

What is the part # on U2?
CJT 117B?


If its a 117B 3.3V regulator:

If its a 3 terminal regulator it might be:
3.2 = output
0 = ground
-2.3 = doesn’t make sense. Where does this come from go to?

Where is the input to the 3.3V regulator derived from?
If the output is 3.2v the regulator seems to be working however I do not know how, if the input is -2.3V?
On U2, what pin has what voltage
This weird negative voltage might be a hint something else is wrong like a grounding problem.

Where is the 12V derived from?

A step-up regulator for 12V?

Plugged or unplugged. Same. No difference.

Laser head is cool. No warming.

U2 is the power regulator.

Today I measured more correctly.

If I put the ground on the leftmost leg

left - middle: 3.3 V
left - right: 4.98 V.

middle - right: 1.68 V

I think the pcb is either multilayered or the back is insulated. I can not trace the connections.

laser input port is just next to 12V power input. But of course there is no voltage on +12V of laser if I do not switch the system on.

I can not see any relay switch around.

So finally I found the 5V.

3 Mar 2021 Çar 17:48 tarihinde Don Kleinschnitz Jr. via Maker Forums <> şunu yazdı:

I guess the board’s input is 12V? I see the jack now, did not before.

why are you looking for a relay?

I am not sure whether I flipped the poles while measuring the voltage across U2 earlier. It looks like U2 is OK, when the system is up and running.
Yes, main input is 12V DC, but it is not directly fed to Laser +12 V. I was wondering where that input voltage is fed into +12V. That is why I was looking for something like a relay.

So, back to square one. The system rarely comes up (Long Press does not work every time (once every ten or less), and then dies of within minutes.

Don Kleinschnitz Jr. via Maker Forums <>, 3 Mar 2021 Çar, 20:41 tarihinde şunu yazdı:

MY guess is if the 12V is switched it would be a MOSFet somewhere near the 12V in the laser connector.