Vigo VG-L7

I recently bought a VG-L7 from WISH sent very quickly as despatched from Austria where I live. It came with controler but no Laser as was written in the description, it also said no controler but one came with it. The price was just under 90€. I then bought the following Laser from Amazon:- KKmoon 3500 mW / 6000 mW / 7000 mW / 20 W Watt 450 nm Blue Light Laser. I understand the 20W is only the Maximum but not continious.
My problem is that having downloaded the driver and plugged in the code USB stick I am informed to download the latest Firmware. To do this I am instructed to use xloader which brings up another window to fill in. Having typed in the C:// users …etc to the place where the Firmware folder is then VigoEngraver_Firmware_V1.3_B20200718.hex baude rate 115200, model VG-L7 then it needs the COM port, clicking the little dropdown arrow there is only COM7. I have then clicked Upload as required but it says uploading but nothing apears to happen I have waited 25 minutes and still not had the message successfull. If someone who has one of these machines could point me in the right direction I would be very pleased and thankful. Maybe the Com port is wrong.

Welcome to the forum Colin.

I dont have this system, but you can check the com port in device manager. Just open the com port tree and see what has been setup with the device plugged in.

1 Like

Thanks for your responce, I will try it tommow.

Hello

I have just purchased one of these Vigo VG-L7 laser machines and when I installed the software it informed me I had to upgrade the firmware. I have tried both methods detailed in the manual using the software or Xloader and using two different laptops running windows 10, but no success.

I have checked I can communicate with it using Arduino IDE serial monitor and I can see the hardware booting up when I switch it on.

Can anyone help, because I cannot use the machine at the moment.

Regards

Paul

I also have a similar problem, maybe you have read mine but unfortunately I have just started a 3 week rehab after rrlecently having a new knee. I will be giving it full gas when I get home and settled down. If I find I can complete everything I will be contributing a writeup for all to see. If you find out could you also inform the forum as that is the idea of a forum, to help all. I wish you good luck.

2 Likes

Not knowing the type of Arduino controller you’re dealing with, sometimes you have to press the reset button before you can start the firmware upgrade.

1 Like

My son and I spent over an hour recently trying to burn Arduino-based firmware onto an ESP32-based device from a Windows machine lots of different ways, and finally tried hooking the device up to my Linux laptop—which worked perfectly. The Windows machine now dual boots into Linux, and now works fine to burn Arduino firmware when it’s running Linux, with no other changes than installing Fedora 33 on a second drive and booting into it. (This is one of the cases where the whole point is direct hardware access and a VM is unlikely to help.)

No idea whether it applies in this case, as I don’t have any Vigo laser engravers, but I understand that the Vigo VG-L7 controller is built on an ESP32, so it’s not inconceivable that it could be relevant.

3 Likes

Well 4 days before I am home so i hope within a week I can get stuck into it. I will note exactly what I will be doing, I am not familiar with some of your technical jargon but will see how I get on Thanks for your reply.

1 Like

I dont know at the moment but the end of this week I will be home again trying to get it to work, I will then know what controler was supplied with the unit. I had no problem running the motors as soon as I had it assembled, now I have the laser fitted I think my problems are just starting. Thanks for your reply.

2 Likes