Version 0.4 of the TinyG config app has just been published.

Version 0.4 of the TinyG config app has just been published. Currently reached via the Configure menu on the TinyG widget’s drop down, I expect @jlauer to make it more visible with a dedicated Config button shortly.
This widget WILL UPDATE the TinyG now! But it still has the occasional glitch. If you notice the TinyG buffer gets stuck after applying, use the reset button on the TinyG widget and then confirm your settings … some may not have been written.
In addition, the widget occasionally fails to read correctly. So before you write some bit of changed data make sure all the other data has been properly read.
Cautions aside, the widget is largely functional for those who need it yesterday, and will continue to improve. Enjoy!

Nice work! I can add a button to make this more visible. This is a huge step for everyone on a TinyG. Thank you Kevin for the code contribution.

Ha! Thank YOU John, for Chilippr and for the TON of help you’ve been!

LOL … I should really re-read what I type BEFORE I post it. I apologize, John … I didn’t mean to come off like I was demanding a button for it. In my mind I was writing “I expect John might make it more visible with a dedicated Config…” and somewhere between brain and fingers “might” became “to”. A button is one way, but not necessarily the only way…

I’ll give it a go soon.
You might want to review this chat with the Synthetos folks for possible implications with your ‘stuck’ issues : https://github.com/synthetos/TinyG/issues/123

I ran a simple test case with today’s version 0.4 - Success!
spjs ver 1.75 running on laptop, CP running on desktop in Chrome 40.0.2214.91 (64-bit). Both Linux

Opened configure, Motor and Axis parameters populated immediately.
Changed one parameter, $xvm, then selected Apply.
Configure window closed, quickly, hmmm, I thought, crash or complete? Reopened configure, Motor and Axis parameters populated immediately, showing my single changed parameter.
Closed Configure, then verified the changed parameter with $xvm on the Serial Port Console command line.

Thanks. I have already encoded a 100ms timeout between commands. But I might try the approach mentioned within…

Good point … I meant to add a success message. It’s on the list somewhere!!

Interesting, 100ms is double Alden’s suggested delay, so if that is revealed as the issue, we’ll want to highlight that.

Hi @Kevin_Hauser
First thank you for building in the config tool. Second let me apologize for a newbie question.
I am new to Tinyg but have been working with Arduino & GRBL Shield for some time. I would like to move to the TinyG2 so I can utilize a 4th axis.
I connect to http://chilipeppr.com/tinyg with the JSON server running and am able to connect to my Arduino Due. I can also connect to http://chilipeppr.com/serialport and run commands.
My question is, if I set up my motors using your utility how do I write that back to the Arduino properly? I click on save, it gives me a warning, and then I click ok. It all seems good. If I close the webpage and reopen your utility the settings persist. But if I run the $m commend from the serial port web page the changes are not there.
The same thing happens if I make the changes via the serial port commands. They all look good but if I disconnect the Due and reconnect the setting are resort back to the original values.
Thank you,
Keith

@Keith_Grunow I believe the answer is here: “I disconnect the Due and reconnect…” The DUE has no backup EEPROM (as does tinyG),changes made to parameters are volatile.
Here are three possible solutions, all of which will make more sense if your thoroughly review the tinyG2 Wiki first: https://github.com/synthetos/g2/wiki
In no particular order of “best”:
Option 1: Recompile the G2 build with your machine parameters
Option 2: Rerun Kevin’s Config widget each time you repower
Option 2A: Review this wiki item https://github.com/synthetos/TinyG/wiki/Chilipeppr-Archive-and-Restore-Parameters-for-tinyG. Restore your parameter set each time you restart G2
Option 3: SPJS - The SPJS widget suppports a preload script option that can be used to automatically reload a preset group pf commands (parameters).
My CP is not up at the moment, so I gen’t provide specifics.
Hunt around in the widget - or search the CP Google+ web - Johnl L has provided a how to but I can’t seem to locate it at the moment

@Keith_Grunow Unfortunately I’ve had some poor luck this year and thus haven’t been able to dedicate much time to any hobby. My intention is definitely to get back involved, but I have some health issues to resolve first.

Fortunately you are getting some help in the mean time.
Best of luck!
-Kevin

That is awesome, I did do a search before posting but must not have searched for the right works. Thanks @cmcgrath5035 for your response.

@Kevin_Hauser , hope you are well soon. All the best!