V-carve in chilipeppr not working...

V-carve in chilipeppr not working…
So I’ve tried a few times to get V-carve to work in chilipeppr and it never loads. I use Jscut to produce my Gcode and drop that into chilipeppr. Other files load just fine. Is there a trick to this? Is the v-carve file too large for chilipeppr? I’d appreciate any feedback. Has anyone else been successful loading v-carve Gcode from Jscut into chilipeppr?

What’s the size of the file? What error do you get?

I do vcarving all the time with Chilipeppr, but I don’t use JScut. I use f-engrave.

John, thanks for always being so quick to respond on this forum, your always ready to help with your software and I think we all appreciate that.
I believe the file was 5mb, I was getting an error that the cach size was full and I needed to empty files before loading this one. Problem was I cleared all the files and it still gave me the same error and wouldn’t load.

Frank thanks for the tip! I didn’t even know about f-engrave, I’m going to give it a try. I wonder though if you’re doing more than just engraving on a part it might be difficult to align and ensure your cuts will be oriented properly if I had to say engrave with f-carve and then cut something out with Jscut on the same piece. I suppose it could be done but might complicate things.

It’s a valid concern. F-engrave let’s you export the cut to svg, so I import that and the svg from JScut (or whatever else I’m using) into Inkscape and use that to align and move my cuts. Once I have them where I want them, I take note of the positions in Inkscape and then edit the gcode for all parts into a single file and use G92 commands to position each part. I made a tutorial of this in my poker card box project video. You can check it out on my YouTube channel if you want.

Nice thanks Frank I definitely want to check that out. Do you have a link ?

Oh my bad ill look up your YouTube channel! Thanks.

5mb is getting to the upper edge of files I’ve seen work. I’m not sure the best way to solve larger files given that I’d have to render %'ages of the file to not overload the browser memory, because it’s the 3d viewer that’s choking on files that large, not the Gcode widget. It seems to me if I rendered every 10th point i could maybe make it work but then the 3d view would just plain be wrong-looking. Anyone have any ideas on approach?

Frank I’m am trying to use F-engrave and am running into a strange issue. When I run the g-code as a test run in chilipeppr everything seems fine. However when I go to run the actual G-code it lift the z-axis and acts as if it’s moving to the cut position, here is where the problem begins. It continues to move past the cut point and then slows down but continues to keep moving very slowly in a straight line away from the cut point.
I’m am running TinyG v8. Have you ever had this issue? I am looking at the settings and there is some Gcode header that I assume it sends to TinyG at the beginning of the operation. Did you have to make any changes there? Thanks for any help you can provide.

Hmm. I can’t say I’ve had that problem. It’s possible I’ve customized the header, but I don’t think so. When you run the GCODE in a simulator like openSCAM does it also have the issue?

@Frank_Graffagnino I haven’t tried any other simulator aside from chilipeppr but I’ll give it a shot. In chilipeppr the simulator works fine…so strange.
Wow the openscam software looks awesome! Wish I knew about this sooner, thanks Frank!
Hey have you ever tried estlcam? I’m playing with it now in free trial and so far I’m impressed and it’s only $50 vs meshcam which is $250!

So quick update. I was running firmware v.14 on my TinyG and decided it was time to update. I installed v.20 and tried to run the F-engrave Gcode again and… It seemed to run perfect. So it must have been a firmware issue with the TinyG itself. Thanks for the tips Frank.

glad you got it working!

Wondering if anyone managed to get V-Carve/JSCut working? I’m trying to vcarve a 14mb file and Chilipeppr freezes up!

I never did, but I would give Laserweb a try. I think it can handle much larger files. It’s also now compatible with TinyG although my machine is currently down and I haven’t had time to test it.