Using the grbl workspace. I can't get auto-levelling to work properly.

Using the grbl workspace.

I can’t get auto-levelling to work properly. The 3D viewer shows that the autoleveller seems to have mixed up units. Set to test every 1mm, but points are shown at 1-inch spacing.

Running onKubuntu 16.04
Browser is chromium-browser Version 57.0.2987.98 Built on Ubuntu , running on Ubuntu 16.04 (64-bit)

Can someone help?

Two things i think

  1. The grbl workspace has a bug in autolevelling where it will just stop from time to time.

  2. The grbl workspace does not support grbl 0.9j. If you want to use 1.1x then use /jpadie. The autolevelling is fixed too.

Thanks for the tip - looks like /grbl is a bit out of date. Unfortunately /jpadie doesn’t work for me either - the 3D view just shows a black screen.

that is odd, @Duncan_McIntyre . It is working for me on mac and windows and on all main browsers (apart from Edge).

perhaps try a cache-flush and hard reload.

If you are using Chrome and have updated in the last month then you should check the flags (chrome://flags) as the latest release seems to have turned off WebGL. Check my recent posts for a pdf of my flags that got chrome working again.

ah. sorry - you have said chromium and linux. quite possibly a flags issue!

Forcing web-gl enabled has fixed the rendering issue, but the mm/inches confusion is still there

there should be no confusion if the gcode is in mm. everything should standardise to mm ok.

there is an issue (if you are using /jpadie) with using inches. I was trying to force the reporting and display to standardise to whatever the gcode was using. but there are a whole bunch of other widgets that seem to want to have a say in the coordinate system, so I am going to give up on the standardisation push. I will try to push a fix later today.

the downside of the pubsub model is that different widgets can have different view of their own importance and which one is mucking about becomes quite opaque. Ideally someone would take them all by the scruff of the neck and do a proper rationalisation and refactoring job!

OK got it now. I think I may have just learnt about Program and Application option defaults in FlatCAM. I thought I’d set mm, but apparently not.