USB issues continue after 20 hours of troubleshooting over 3 days

I sincerely apologize for my earlier comments. I had sunk over $1,000 into the laser prior to the 30 hours I spent troubleshooting it. I was extremely frustrated and I took my frustration out on the forums. I don’t understand Linux, and as much as I hate windows, I didn’t want to learn a new system. I should have explained before that I had the laser “working” at one point. It was etching and just not cutting through the acrylic I had, but being the novice I am (i.e. completely ignorant of mirror quality and focal length), I kept increasing the power %. I know from countless forums that I need to install an ammeter as the % is an accurate reflection of what the power supply is producing. I ended up tripping the breaker in my house and frying my power supply at the same time. Long story short, I wasn’t really angry at the people in the forums, I was angry at myself for putting money into a machine I wasn’t qualified to operate. I wanted to toss the laser out the second story window of my house and luckily I was able to refrain and get some sleep. I’d had maybe 8 hours of unrestful sleep while I was troubleshooting the laser. I’ll check the connections you mentioned and see if it makes sense. My only real concern with a new controller on the way is having a bad connection that costs me my new board. Although, as I said before, I don’t see any damage on the current board.

I sincerely apologize for my earlier comments. There is no excuse for them.


The K40 is not a ready to use machine and especially not for someone who’s never used a laser cutter before, ie never taking a laser cutting class at a maker space.

I recommend to anyone who will listen to ready EVERY entry in the Quick Help sections on
and then go through the K40 Intro on this site.( New to K40: Start Here ).

I read every section of the first link before I even ordered my machine and still learned stuff along the way but I knew enough not to damage my machine. example, water temp less than 25C or shut it off. What I saw, and the K40 Intro here misses, is the dozen or so people who ruined their laser tube in less than 1 year by not knowing the current flowing through the tube… ie the digital displays are worthless and should only be used to set the power to the lowest setting to mark something just to test the machine. From that point forward it should not be used until you know what setting maxes your current at 18mA. On may that setting was 40% power on the digital display…

Your problem looked like it was USB connectivity and because you were not able to get Windows to work, and failed to tell anyone here you’d over driven your machine, popped a breaker and killed your LPS… I mentioned using Linux because it just works and seems to work very reliably but it is not Windows so yup, there are a few things to look up like what lsusb does, what dmesg does and follow the instructions for Linux on k40whisperer and/or meerk40t or you can learn how to trouble shoot Windows device drivers…

Good luck.

1 Like

Thanks for taking time to cool down! Most of us probably know frustration. As far as I’m concerned, if this turns into an effective reminder for you to sometimes “back away from the keyboard” it’s worth the trouble. :smiling_face:

Our (site leadership) goal is that after you have read and understood all of the posts in the Getting Started with CO2 Lasers category, you know what you need to know to run a K40. We’re not quite there yet; maybe we never will be, but we can try.

We are a bit annoyed that these K40 units are sold as if they are ready to use; it’s deceptive marketing practice at best. It definitely takes an investment of time. We can’t fix that, we can only help people learn what else needs to be done to make one work.

I think you are going to need a systematic, patient approach to get back to a working laser. The good news is that you should be able to end up better than new but the bad news is it will take time and money…

  • Where are you in the process of replacing your power supply?
  • Only with a known-good power supply, discovering whether you need a new logic board.
  • You probably need to replace the tube; needing to supply more and more power for the same cut is a sign that the tube may have been damaged.
  • The fact that it never cut, only etched, is likely a sign that you needed to align it (we have multiple resources listed for that in the intro category).

Also, may I strongly suggest changing your “handle”? I think that “K40Stumped” might just reinforce feeling defeated, and if you do decide to do all the work to get to a working K40, do you want to be reminded of the trouble each time you post? Because after cooling down and apologizing, we definitely welcome you to stay and learn with us!


@GreggA Thank you for taking the time to explain why you are frustrated and why you reacted the way you did. I second what @mcdanlj said. I I’m sure that everyone here has shared your frustration when unable to troubleshoot a problem. The older I get, the more palm to forehead experiences I have!

I hope you noticed that everyone here is rooting for you and support you, even when you get frustrated. We pride ourselves here in being different from other boards. Just like families we will say and do things that may not sit well, but in the end, it is our common goal of finding acceptable solutions that unites us. In fact, when you do finally get your machine running you may take pride in knowing that you may have helped the next person in need with your experiences.


I’m sure I didn’t seem very supportive, but I do hope K40Stumped does solve their issue, I just personally have issues with some of what I perceived to be their behavior, but they definitely should feel free to ignore me and my opinions. I’ve seen some people behave very badly, and I felt they were doing the same, but maybe I was wrong, and if so they should not take what I said personally. I do hope they find solutions and their machine ends up working.


Ok then… you aren’t the first K40 user to be overwhelmed by a K40’s aberrant behavior.

It’s best we reset and get a baseline of information at this point.

Please prefix your answers with the associated question label (i.e. A.x) to help us keep track …

A.1 At this point, was this a stock machine including a stock laser power supply (LPS)?
A.2 What software were you using to drive it?
A.3 was your usb connection reliable?

A.3 Did you replace the LPS with the HY-T50 to correct this situation?
A.4 Did the machine work after the change of the LPS? If not, list what did not work?
A.5 At what point in the series of events did you lose the ability to connect to the machine via the usb.

Post pictures of:

  • Control panel front
  • Control panel back
  • LPS showing the connections
  • Nano showing as much of the wiring as possible

My Observations:

  1. The K+ on the panel [I am assuming it is a digital one] is normally used to enable the LPS and is connected to the K+ signal on the LPS if it has one. The K+ on a digital panel becomes ground when the “Laser Switch” is asserted this is used to enable, not fire the LPS.

  2. Your new supply does not have “K” signals and provides only one enable port and that is WP. In this machine, the K+ is connected to TL which is a LPS digital control INPUT port. TL & K+ also are connected to the LO signal from the nano which is an output. This configuration has the output(LO) of the nano grounded as long as the “laser switch” is on. Although probably not damaging, Not good.

  3. I am pretty sure that we had another user that used the HY-T50’s 5VDC to power the NANO 5V and had trouble. Although I cannot seem to find my source I am pretty sure that the spec on the HY-T50 5v is 1A which may be marginal capacity for a nano…

  4. WP is currently connected to G. This enables the LPS all the time! Not safe!

My working theory;
There is a low voltage power supply problem that is keeping the Nano from connecting. USB ports are very sensitive to power fluctuations, ground loops, and noise.

  • The HY-T50 LPS cannot reliably power the Nano. Inadequate 5V capacity can be causing USB problems.
  • The grounding of the Nano’s LO output (via K+) may be causing some kind of ground loop and keeping the USB from connecting
  • The grounds of the panel, LPS, 24V ps, and nano are not all connected together.

What would I do?:

  1. Disconnect the K+ signal from the LPS. Warning: the WP is already strapped to the ground so the laser is unsafe and the panels “Laser Switch” will do nothing.
    ** Disconnect WP from ground and connect the K+ signal to WP.
    ** Using a DVM verify that when the “Laser Switch” is asserted WP goes to ground.

  2. Purchase an external 5VDC supply and wire it to the nano’s 5V input. I would recommend a capacity of around 5A. Ensure that all power supply grounds are connected together. Here is an example supply: *

  3. Verify with an ohmmeter that the ground points on the LPS, Nano, Nano power supply, 24V power supply, and control panel are all connected together.

  4. Go back to the working software configuration you had before the machine blew the breaker. Try and connect the nano.

Even if my theory is wrong these things will get us to a good starting baseline.

*As an Amazon Affiliate, I earn from qualifying purchases.


You were honest and shared your opinion with the information presented, that’s what counts the most.

1 Like

Thank you all for being so supportive. There are a lot of suggestions to process. I want to start by saying that I did watch most of the videos I could find about upgrades prior to receiving my system. When it arrived, I upgraded the water pump, checked the electrical connections to ensure everything was safe electrically, added an air assist (albeit the blue one that people didn’t like opposed to one that was created by a 3d printer), aligned all the mirrors (using John Carber’s 92 minute video, watched the entire thing before and then again during as I was getting to the final mirror and not able to move it and had to start over), removed the bed, added a little lift (not sure on the proper name), bought a cheap AC intake vent to attach to it, and upgraded the lens to an 18 cm lens. However, in all the research I did, I didn’t see anything pertaining to how important quality mirrors were and must have glazed over focal length despite buying the lift/jack device until after I fried my power supply.

After frying the power supply, my research led me to believe that I needed a stronger power supply. Research led me to How to upgrade your K40 power supply - and he recommended an HY-T50 Power supply and said I would need an external power supply for the 24V. He didn’t mention the 5v being an issue at all. He showed wiring diagrams. However, the M2 Nano had extra wires that weren’t included in the diagrams I found. I connected them purely from the plugs they had been previously attached to except the K+, which had no corresponding connection on the HY-T50. I don’t recall where I found a schematic showing the K+ attached to the TL connection on the power supply, but I took it on faith. After installing the new LPSU, my 24v external power supply hadn’t arrived yet and that’s when I came across videos explaining how important mirror quality and focal length were. I bought the recommended Silicone mirrors and aligned them since I didn’t need the 24v power supply and manually moved the gantry system to burn holes in 40-50 post-it notes.

I didn’t write all this in my initial write-up of the issue for two reasons. The first being TLDR as I’m guilty of doing this myself from time to time and the second being it was a little embarrassing frying a power supply after an hour of use. Especially considering that I was electrician for the Navy from age 18-24, which feels like a lifetime ago.

Also, having been in Navy Nuclear Power, I’m naturally a little overconfident at times. Under most circumstances it suits me well as I can usually learn anything (given enough time of course) and have taught myself how to write Visual Basic (VBA) code purely from Youtube videos. There is very little I can’t do in VBA and if I wanted to do it, I’m certain I could find a video on how to do it. With K40 lasers however there are far fewer youtube videos than there are for VBA. Especially videos pertaining to problems with Windows not communicating lasers.

If I knew a professional could have solved my problem in a short amount of time, I would have hired someone immediately as windows isn’t something I wanted to tangle with. However, after spending 20+ hours investigating, the last thing I wanted was to hire someone at $50 an hour to spend the same 20 hours and not be able to find the problem. That would end up costing as much as I had already spent on the laser itself. I haven’t had good experiences with Mechanics, Plumbers, or even Doctors in the past diagnosing issues correctly and it has cost me way more than I was expecting 9 times out of 10.

I’m going to address questions from donkjr first. As this is my first forum I’ve ever joined (outside of comments on Youtube videos), I don’t know how to use quotes.

  1. Power supply was fried when I was using the stock K40 power supply. The HY-T50 seems a lot more capable and although I cant connect to my computer, I have tested the laser will cut holes into the acrylic at 2 inches.
  2. I was using K40 Whisperer with designs I created in Inkscape.
  3. USB wasn’t reliable at first. I was having lots of interference issues with my air assist as I ran the power cord through the same hole as the USB cable. It was timing out the connection and I drilled a new hole in the case and routed the cable through the new hole. The timout issues stopped right after.
  4. After the removed the power supply and saw a burned transistor, and a blown fuse, I replaced the power supply with the HY-T50 (although I debated finding a RadioShack and replacing the transistor and was surprised to see that RadioShack still existed and had 3 locations in Las Vegas).
  5. The only thing that didn’t work after installing the new power supply (and the 24v External Power supply) was the connection to windows as I was unable to download the to have K40 Whisperer send instructions to the laser.
  6. I’m assuming I lost the ability to connect to the laser after I fried the power supply, but I can’t be certain.

I will post pictures of the inside of the box, but they aren’t pretty as I used more wire nuts than I would have liked and bypassed the pump low flow interlock as I don’t have a low flow switch installed. Also, I don’t like how the manufacturers made all the wires from the power supply to the M2 Nano blue and how small some of the control wires. After stripping them, they had like 4 thin strands of wire each. I thought about replacing all the wires in the system with more easily identifiable wires.

I’m not certain 1-4 are entirely accurate. If I had shorted any components to ground, I would have popped a fuse or fried the new power supply immediately. Also, 4 certainly isn’t accurate as the Laser wasn’t constantly running, only ran while test firing it, and could be shut off by pressing the “Laser Switch” on the main panel. That being said, I’m almost certain some of what you said in 1-4 is correct as I was getting a 5v drop somewhere I wasn’t expecting. Unfortunately, I left my multi-meter at work and cant test which one that is at the moment. Tomorrow night I will certainly test it and update the forum.

I will try #1, but I’m pretty certain its only grounded because it should be connected to a low flow switch/interlock and the K40 system doesn’t currently have one installed. Also, the laser switch currently works.

I will purchase a 5v external power supply because even if it doesn’t happen to be required, its always nice to have more power.

I have previously verified the LPS, Nano, Nano Power Supply, 24V Power supply and the control panel grounds are all connected together by ground connections to ground. However, I was creative with this as I was an electrician before and used the WP terminal as ground since it was connected to ground (i.e. the same node).

There is no way for me to go back to the working software configuration I had before I blew the breaker. I had the drivers for LibUSB installed on the previous configuration and unistalled them as many trouble shooting videos instructed me to do prior to reinstalling them to try and fix communications issues with the laser.

Again sorry for these pictures. I would have never used all blue wires to connect to the M2 Nano if I had designed the system, but I was working with what I had. Also, one of the wires came out of the LO plug on the M2 Nano and I had to insert the white wire into it and wire nut it onto the blue wire initially inserted there. I have tested continuity between the end of the connector and the wire nut several times to ensure the connection is secure. This is the main reason I took the time to draw the schematic I used as it is pretty hard to follow without it.

Also, I’m not sure how to change my username. I checked the preferences tab and it seems like I can update emails, add information about myself, etc, but I don’t see a way to change my user name outside of setting up a new account.

That’s a lot to absorb :).

In regard to the K+ connection to TL

Keep in mind I am looking at photos of wiring while imaging the actual wiring :slight_smile:

This picture shows the connections from the panel.

Wires labeled as such:
Ground = . . .
In = --------
5V = x x x x
K+ = __ __ ___

Then I go to the picture of the other end I see:

The Gnd, IN & 5V connected to the LPS
I do not see the K+ connected to TL and TL has only one wire at the LPS
and one wire at the Nano.

Is this because:

  1. You removed them before taking this picture
  2. I am not seeing the whole picture
  3. The schematic is wrong

Other wiring observations:

This picture shows :

  • WP is connected directly to G
  • WP is connected through a white wire to a black wire

Where does that black wire go?

Not exactly sure what you mean by this statement?

Cant, you do a reinstall? We can’t proceed without software to drive the nano???
We have the Whisperer guy on this forum so I assume he can help us get back to where you were.

@Scorch … help?

To use the quote just highlight text in a post and a grey box will come up with ""Quote. Click on it to transfer the text as a quote to the edit screen.

We only recently found out this supply might have marginal capacity.

I am still thinking that your USB connection problem is related to grounding or power capacity that showed up when you replaced the supply

1 Like

I found the other user that had this problem:

20ma is definitely not enough capacity to run the Nano.
My guess is when you connect the USB the nano is being mostly powered from the USB power which can create an unreliable or inoperative connection.


You are correct with regards to the wire connected to the TL from the control panel. I disconnected it from the the TL terminal on the LPS when you said it didn’t belong there to test to see if the computer could find the laser. However, I forgot to reconnect it prior to taking my pictures. Currently, I’m running a retail shop inside a swap meet in Las Vegas. We are only open on Friday, Saturday and Sunday. We are able to work on remodeling our booth on Thursdays and I expanded my shop two Thursdays ago. TLDR: I have been working/commuting for roughly 14 hours a day and that’s why its slow for me to respond. Its also the reason I spent roughly 30 hours troubleshooting on Monday, Tuesday and Wednesday of last week.

That is correct. I explained that above. Its required to be connected to ground to bypass the water pump low flow switch that is not installed in the stock K40 laser. The original LPS does not have a WP connection to even allow for this protective feature.

The black wire goes to the ground of the external 24V power supply.

There is a white wire connected to a wire nut from WP which is the same as ground because WP is connected to ground using the U shaped black wire. The white wire is
connected to a second black wire that is straight and connected to the blue ground wire from the M2 Nano and the ground wire of the 24V external power supply. From an electrical standpoint, the M2 Nano, the 24V External Power Supply, and WP are all connected to ground from the same node, I just used 2 wire nuts and two terminals on the LPS to do it. I previously said it wasn’t pretty, but it allowed me to connect the 4 things I wanted to ground (WP, the Control Panel on the top of the machine, the M2 Nano, and the 24V external power supply) to ground without having to put 4 wires into a single wire nut or terminal. I’m hesitant to connect even 3 wires using a single wire nut or terminal, but I didn’t want to add a third wire nut to the mix. If everything had worked after my connections were made, I would have wrapped all the wire nuts with electrical tape, but I left them un-taped in case more rewiring had to be done, which appears to be the case.

Thank you! This has made things much easier.

Sadly, this is what drove me to the forums to begin with. K40 Whisperer install program requires communication with the laser to install the K40 drivers for the laser. When I went to install the drivers, the installation program had the message “0 Devices found” and wouldn’t proceed beyond that point.

This makes sense to me now.

Okay. This makes sense why the computer couldn’t read the M2 Nano. It just didn’t have enough power. Do you have any recommendations for a good 5v power supply? Preferably external. I guess I have to know either how many amps it will require or the total wattage. Perhaps the manufacturers of the M2 Nano have that information posted. I will check it momentarily. Thank you so much for your help! I’ll let you know how it goes. It will probably be another week or so before I can get a third power supply (5V) delivered as it took 9 days to receive the 24V power supply I ordered on eBay the last time.

you might have a few 5V power supplies already… USB phone and tablet chargers are 5V chargers if they are not USB-C type. They are usually 1-2A so should easily power the M2 Nano…

Okay cool. I’ll check the power packs I have around the house, which probably isn’t many though as I tend to be a minimalist in the area of no longer used electronics. However, I’m sure that will change with my new hobbies.

Then your local thrift store will probably have some cheap. Do what you have to do, just offering ideas so you don’t have to wait a week for a 5v power supply.

I don’t think you understand how ‘drivers’ work by that statement. If it could talk to the laser, it wouldn’t need a driver. In Windows ‘drivers’ seem to be the ‘details associated with the devil.’ They or the same animal exist in all systems.

Generally drivers exist in the HAL (Hardware Abstraction Layer) to eliminate the OS from knowing the specifics of a piece of hardware. The OS just tells the HAL to write/read or whatever to this device, it’s up to the HAL to select the proper ‘driver’ that knows what/how to interpret the codes and control the device. In a nutshell…

I have done lots of things with arduino types, but I do not know how these K40s are configured to use them. Looking at the hookup, I would think the nano would use the 5 v from the USB connector. You should be able to talk to the nano with avrdude and see if you can connect to it. If so, it’s up. Why is it plugged into the 5v supply anyway? Maybe someone can answer that that knows them better. A common ground should be sufficient, I would think.

Order a cup of coffee, sit down and relax. Few things are so important that you don’t have time to stop and think about what’s happening.

You will get it, it take time and patience.

Good luck and take care… (:o)

The “Nano” talked about in the K40 is not an Arduino Nano, it’s called an M2 Nano or NanoM2 and is a custom made controller board for laser cutters. Maybe they didn’t wire the 5V from the USB to the 5V on the board and expect only external 5V from 5V input connector.

Once you get the power sorted out, then as long as the m2nano board isn’t fried, you should be able to find the device.

The reason that I had suggested trying Meerk40t is that while Whisperer needs a different device driver loaded, Meerk40t can use the default drivers. But “0 Devices found” when trying to install the driver is probably closely correlated with your finding that Meerk40t wouldn’t work either and that’s either not enough power to the m2nano or the m2nano is fried.

Just to set expectations: When there are lots of details, expect to have to repeat a few details from time to time. The folks trying to help you can’t re-read the entire thread for every question they have while trying to help.

I think we have asserted that the core problem is the lack of 5V capacity to the controller.
Lets focus on fixing that first…

I don’t know the power specs for the M2Nano but would overpower it to be sure.

Certainly you can use a 5V wall wart or other household wart. Since they are not designed to be mounted it may be more trouble than it’s worth to install it in the system vs a new open frame supply.

Below is the supply I recommended earlier.

I like to install these supplies with a inline blade fuse** in line with the output.
Your option … to decide.
You can get a carrier and fuse at home and auto stores or below is one. I would fuse it at 2A but have 5A fuses ready.

** many will suggest fusing a peice of electronics this way is futile in that by the time the fuse blows the protected circuits are already toasted. Perhaps… a debate for another day but not here.

Haha. Too much coffee and caffeine in general (2-4 cups per day and about 6-10 Diet Coke). Neither of which is really great for me. I just needed sleep, which I finally got. It had been 7 days since I’ve had a good night’s sleep. I got 7 hours last night, which isn’t a ton, but it helped a lot.

I thought I understood drivers before this project too, but the installation program wouldn’t move forward. I’ve installed a driver or two in the past only to realize the device was still unplugged from the system. So, when I encountered this, I was really stumped.

Even if the board is fried, I have another one arriving today. I found a power pack in my garage that’s 5.1V and 2.2A. That should be fine right?

I wasn’t trying to be rude here. His earlier comment told me not to connect the WP connection to ground and had implied I would destroy my laser by doing so. So, I specifically addressed that concern above. However, I didn’t know how to use quotes in forums before that and he may have missed it, so I explained it again. Also, my phrasing isn’t perfect as English was my least favorite subject throughout all of my schooling. I use periods when I should use commas and other times my sentences end up way too long.

I completely agree with this assessment from everything I’ve seen. I should have both the 5v power supply and the new controller installed (if needed) tonight and I will know for sure. Since I have Meerk40t installed, I will try that if the K40 Whisperer program doesn’t work.

I agree. Its definitely harder for me to justify adding another power supply and making more connections in the case with so many wires running around to begin with, but I definitely want the laser to work, so I’ll try everything that makes sense.