USB issues continue after 20 hours of troubleshooting over 3 days

I can’t get my computer to recognize my laser. I’ve tried just about everything and read every single forum on the internet to try and find answers. Each forum posted seemed to have no resolution except the person who had a disconnected plug on his controller. Here are some pictures:

Problem with USB Device:
image

Error Code 43:
image

Installing K40 Whisperer:
image

0 Devices Found:
image

How my laser is currently wired:

Some notes:

  1. Gantry goes to home position when laser turned on (as expected)
  2. Laser test fires with no issues.
  3. Tried using Zadig to install the libUSB driver

Results:
image
image

Now as I’m writing this explanation of the problem, the Unknown USB Device (Link in Compliance Mode) issues were resolved by a Windows update. However, the laser doesn’t appear anywhere now. There is a libusb-win32 device with no description and the drivers still won’t download as it still says “0 devices found”

Please help as I have no idea what to try next.

I see you are using K40 Whisperer. I note that Meerk40t uses a different driver. If it works and Whisperer doesn’t, it would say that driver installation is somehow the problem. See #k40:meerk40t for more details. If both of them don’t work, you might instead have a hardware problem. It’s useful having two different implementations that work in different ways to help diagnose hardware vs. software issues. :relaxed:

2 Likes

Thank you so much for responding! I tried Meerk40t and it still won’t connect to the laser. I’ve got the suspicion the m2 Nano might be bad, but it shows no visible signs of damage and the laser returns to home when I power it on.

Also, the laser appeared again in the Device Manager, but its showing as two USB devices that have issues like the first picture. Why would it show up twice?

Not that Microsoft Windows isn’t a wonderful operating system, but it’s device management is often a PIA and troublesome. If you know how to make a Bootable USB drive with Linux/Ubuntu on it and see if that works. https://linuxize.com/post/how-to-create-a-bootable-ubuntu-18-04-usb-stick

I’ve sat through enough tech classes where the first 1-2 hours was dealing with Mac and Windows installation issues that when I started teaching classes I would make a customized version of Ubuntu on a bootable image and have students make those at home and verify they could boot into Linux before class time. Then there were only a handful of WiFi connectivity issues often solved in a few minutes.

The bootable Linux stuff doesn’t change anything on your hard disk unless you decide to do that and so you can try and install anything you want into the bootable system and when you shut down, Windows runs like normal and if you booted the thumbdrive again, it would boot like it was the first time it booted, ie a clean boot. I’ve tested lots of software and hardware this way.

And it gives you a jumpstart on learning what Linux is and the Raspberry Pi since it runs Linux too. Since the year 2000, I’ve only run Windows in a virtual machine if I needed to run it at all.

2 Likes

Okay so I installed Ubuntu. It seemed very basic and easy to navigate, but I couldn’t figure out how to install new drivers from Ubuntu. Since most of your comment deals with the installation of the program, do you know how to locate the laser in Ubuntu and install the drivers?

I’m just going to buy a new controller and cross my fingers that is the issue. It doesn’t seem likely, but going down rabbit holes with new programs and new operating systems didn’t seem like what I want to be doing either. I was really hoping that I messed up the wiring or was missing something basic, but I guess I got all that correct and Windows and K40 Whisperer are to blame…

There are no drivers to install in Linux, that’s why I recommended using it. Devices show up in the /dev directory but I generally will open a terminal window(console it’s sometimes called or a command prompt) and then type ‘dmesg’ which will show you all the kernel messages and the last ones will be the last thing you did. So plug in the machine and run dmesg and you should see something like /dev/ttyUSB0 or /dev/ttyACM0 and that will be the device to connect to. There are probably graphical ways to see this but I like fast results and I’m a 10 finger typists so the console is the quickest way to get results.

2 Likes

unless my meds (recent surgery) are messing with me…

Why is the NANO’ s output LO connected to K+ on the panel?
Is the panel in the drawing a digital panel?

Check all the voltages for proper levels.

The 5V from the HY-T50 may not provide enough current to run the nano and also may be causing interface problems. Try beefier 5v supply.

This is the exact problem with these kind of forums. Either no one ever finds the reason for the error they are having or don’t post the solution they found. I posted a similar issue today after doing over 20 hours of research and troubleshooting and two people replied. The first one told me to use a program other than K40 Whisperer and the second told me to use Ubuntu with no direction on how to use it. Conclusion: forums like this are utterly useless.

I can understand you are frustrated but it may help if you remind yourself that you aren’t paying anyone on these forums for support.

These forums are a place where like minded individuals can share information. But you are expected to be able to test and diagnose your own issues. Sometimes that means running software other than what comes with your hardware. It may mean doing things that you have never done before and maybe even running an OS that you are unfamiliar with.

The people on these forums can be very helpful but if you expect them to spoon feed you solutions then maybe DIY is not for you.

For the record, I have no idea what error code 43 means. I don’t run windows. But the “device descriptor read/64, error -71” and “device not accepting address 13, error -71”, in the above comments, implies either a hardware issue with the usb device/hub or the user needs to add “use_both_schemes=y” to the usbcore module. But since you have no idea how to use ubuntu, this probably means nothing to you.

2 Likes

I mentioned using a bootable version of Ubuntu so you could test your hardware without all the crap Windows throws in the way. You didn’t understand that Linux has all the USB drivers already installed and gave up because you didn’t know how to install unneeded USB drivers… You should have been able to just follow the instructions for installing K40 Whisperer on Linux and connect to your laser the way the K40 Whisperer describes.

Or you can re-install Windows and see if that works.

2 Likes

Venting your frustration at people is extremely motivating and will encourage them to want try harder to help you. I’m pretty sure that’s how that works. Or, maybe not?

If you want to pay for support, you may or may not find an opportunity to do that. You might be the target market for a Glowforge, Dremel, or other commercially-supported product.

If you want to be part of a community that help each other, and recognize that everyone is a volunteer and no one is obligated, then you are welcome to participate here at Maker Forums on that basis. If you bring an open mind to a perusal of the content here, you will see that many people have gotten actual help. The fact that some questions aren’t resolved doesn’t prove that no problems are resolved.

But if “forums like this are utterly useless” to you then I very strongly encourage you to stop wasting your time here; it won’t be a good experience for you or for anyone else.

In any case, reviving old threads merely to abuse the forum will be considered abuse and moderators reserve the right to delete rather than to respond in future.

2 Likes

I have moved this complaint and responses out from the Smoothie forum (this has nothing to do with Smoothieware) into the thread that engendered the complaint.

2 Likes

ok then just try the above … you will note that it does not require software changes to check voltages.

I am pretty sure that a HY-T50’s 5v cannot reliably run a Nano.

3 Likes

Conclusion: forums like this are utterly useless.

In this sort of situation, it has sort of become a tradition to link to this semi-famous article:

I can understand you are frustrated

I personally can’t, all I see is entitlement.

If you want to pay for support,

I routinely get paid hundreds of euros per hour for help this person is being given for free. Frankly this is more shocking than anything else.

3 Likes

If you ever get the driver to detect, such as connecting it and getting the default windows driver it. MeerK40t would be able to use that and rule out driver configuration issues. Odds are pretty good the board is just screwy, but if you detect the device at all, MeerK40t would be a help there, if not connecting to the windows driver but also giving you better error messages if it does connect.

Most folks plugged it in and it worked.

4 Likes

I wonder if the OP replaced the USB cable, changed USB ports and tried using a USB hub just to rule out the “standard” things.

There was a time I felt bad because I was always having to know about hardware compatibility with Linux and even build kernel modules when someone was kind enough to reverse engineer drivers. And then maybe 15+ years ago I helped a friend re-install Windows after 30 minutes on the internet without virus protection saw massive viral infestation. Doing as much as we could offline I remember installing a mouse driver and the anti-virus software popped up warning us the mouse driver wanted an internet connection. It was all downhill from there as lots of friends and coworkers dealt with stuff like drivers disappearing, returning from suspension with devices not showing up and having to reboot anyways, etc etc.

Dealing with lsusb, dmesg, /etc/udev/rules.d and adduser userid dialout stuff is a cakewalk compared to the hidden magic and voodoo going on in Windows.

And while I’ve never had the chance to try Meerk40t I’m ever so appreciative of the work you’ve put into it. The moment I heard K40whisperer existed and ran on Linux I found my K40 and ordered it and from what I’ve read, Meerk40t really closes the gap between what can / can’t be done with the stock M2 Nano controller.

3 Likes

Do unto others…

2 Likes

The K- (TL or LO) input needs a inverted PWM signal (pull down, open collector) but the Arduino PWM pin delivers a normal PWM. So you either can invert the signal with a mosfet (like on most 32 bit boards) or you can use the K+ (TH) input of the LPS. Also make sure the signal is 5V (not 3.3V) or you won’t get full power.