Update....I purchased a PI 3 and now have it all hooked up.

Update…I purchased a PI 3 and now have it all hooked up. The Pi is running the JSON server, and for now I’m using my MacBook Pro to run Chilipeppr. Everything connects fine, but when I ran my first gcode file, the CNC was pausing a lot. How can I fix that? The PI is USB connected to the CNC, and the MacBook Pro is connecting through WiFi to the PI.

Send more lines at once. Configure that in gcode widget settings

Thanks. I’ll give that a go.