Turn on laser

Haven’t used Laserweb in combination with the Elekslaser for years. And somehow my settings are gone…

When I hit [Laser Test], then it fires. But the laser does not turn on when I try to cut a shape. It drives me nuts…

Any hints what I missed?

My Settings:
$32=1
Gcode Start (default):
G21 ; Set units to mm
G90 ; Absolute positioning
M4 S0 ; Enable Laser/Spindle (0 power)

I would make sure that the marking input on the LPS is working also.

If this is a k40 style LPS the L signal (rightmost connector) is the port for modulating the laser.

I would disconnect that port wire and gnd it temporarily. Make sure that laser is enabled.

@donkjr The Eleksmaker is a Diode Laser, so no LPS there.

@Kurt_Meister If the [Laser Test] button works, then at least your firmware settings are ok. Did you start with the [Generic GRBL machine] profile in LaserWeb? (hit apply after selecting the dropdown)

You should also check the Gcode settings in LaserWeb:
[GCODE GENERATOR] should be default
[LASER INTENSITY] should be S
[PWM MIN S VALUE] should be 0
[PWM MAX S VALUE] should be 1000 (grbl default)

1 Like

Thanks for your reply. :slight_smile:

Problem solved! The laser worked perfect. It was the CAM part, which caused the problems. With the comment from @Jorge_Robles I was able to solve the issue: https://github.com/LaserWeb/LaserWeb4/issues/457