Trouble with Z probe

smoothie-forum
(JadedJak_SW) #1

I am using Smoothieboard on a homebrew Prusa i3. Today I just added an inductive sensor and got it all wired up for use with my 24 volt system and confirmed that it is working with the M119 command.
When I click Z home it doesn’t do anything except reset the displayed home position to 0.00 in Repetier Host.
If I use M30 it probes but doesn’t do anything unless the probe is not active.
I have used the G32 command but it only seems to probe the first point (z motion), the second and third points it just travels to but doesnt stop to probe.
When I try to print something I can see that the leveling strategy is working because the z axis motors are moving with every X,Y action. But its way off in certain places.
Finally, it is printing at least 1mm too high.

With my Printrbot when I press Z home it uses the probe to find the bed then sets my z location to 0.00. I can configure the offset with M212 then use Slicer to fine tune it between prints. Is there any way Smoothie can work in a similar fashion? Or can anyone here provide a step by step guide to actually printing with the Z probe?

Im going back to a standard end stop until I can get this figured out because its unusable in this state.

Thanks for any assistance.

# Endstops
endstops_enable                              true             # the endstop module is enabled by default and can be disabled here
#corexy_homing                               false            # set to true if homing on a hbit or corexy
alpha_min_endstop                            1.24^!            # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop                            1.25^            # NOTE set to nc if this is not installed
alpha_homing_direction                       home_to_min      # or set to home_to_max and set alpha_max
alpha_min                                    0                # this gets loaded after homing when home_to_min is set
alpha_max                                    185              # this gets loaded after homing when home_to_max is set
beta_min_endstop                             1.26^!            #
beta_max_endstop                             1.27^!            #
beta_homing_direction                        home_to_min      #
beta_min                                     0                #
beta_max                                     195              #
gamma_min_endstop                            nc           # Normally 1.28^!
gamma_max_endstop                            1.29^            #
gamma_homing_direction                       home_to_min      #
gamma_min                                    0                #
gamma_max                                    190              #

optional Z probe

zprobe.enable true # set to true to enable a zprobe
zprobe.probe_pin 1.28v # pin probe is attached to if NC remove the !
zprobe.slow_feedrate 5 # mm/sec probe feed rate
zprobe.debounce_count 100 # set if noisy
zprobe.fast_feedrate 100 # move feedrate mm/sec
zprobe.probe_height 5 # how much above bed to start probe


Imported from wikidot

(Arthur Wolf) #2

If you want G30 to reset position, do G30 Z0

I’m not sure why G32 would act this way though.

(JadedJak_SW) #3

Thanks for the tip on G30 Z0. I pulled the probe off and am just going to use the thumb screws on my bed to make sure its level, at least until more people start using Z probes.

(trevor byers) #4

Ever figure it out mine seems to be doing the same thing.