Tried using touch plate today.

Tried using touch plate today. As soon as it makes contact the TinyG seems to lock out. Connection is to Ground and ZMin. After contact I can’t use the jog function like X or Y until I reset the machine.

I recall an old version of firmware having that issue.

[fb] firmware build 440.20
[fv] firmware version 0.97
[hp] hardware platform 1.00
[hv] hardware version 8.00
[id] TinyG ID 5W3249-CEJ

If you turn off the funnel icon in serial port console, it may show the error tinyg is reporting back after you finish probing.

“er”:{“fb”:440.20,“st”:204,“msg”:“Limit switch hit - Shutdown occurred”}}

Did you try homing only for z?

No I just used the Touch Plate Widget.

I mean config z for homing only not homing and limits.

No I did not… So I assume this is a command setting in Serial Port.

You can use the config widget or set with serial command. How did you config your machine if not using the widget?

I dont think I ever set switches up during initial setup. This could be the issue. So I should probably use the $ZSN = 1 right and set all others to 0 as I don’t have limit switches?

[zsn] z switch min 2 [0=off,1=homing,2=limit,3=limit+homing]
[zsx] z switch max 1 [0=off,1=homing,2=limit,3=limit+homing]

Current Dump

Yes, you have no switches so can’t use limits but you can use z homing using conductive material and conductive bit wired to act like a switch from z min and ground on TinyG. None of the other limits should be wired or enabled.

Thanks it’s set and running now…