Total bummer. Chilipeppr/ Chrome will not load my file.

Total bummer. Chilipeppr/ Chrome will not load my file. I’ve been working on the edge of memory size where I have to clear memory and sometimes the file will fail to load, but reloading has always worked, until now. I went for a more complex and complete image and it just will not load. This is a very big limitation for 2.5D and 3D because the size of the file goes up by the square of the x y resolution. At the resolution I need for good cuts that size is limited to about 100x100mm depending on the image. If there is nothing that can be done this will make large pieces of art work impossible with Chilipeppr. Breaking up into pieces that fit seamlessly is not a real solution. I can live with the barfing on load and having to reload but for now I have to go back to Mach3 to get anything but tiny 2.5d projects milled. I tried several more large files (~25MB) that all failed to load. Not good.

What if you disable the 3D viewer and drag in the file? Or use one of the tablet workspaces like where there is no 3D viewer.

I need to get back to it. But try my workspace at /dchote

Nope, disable 3d viewer nor /dchote work. Very easy to duplicate as it is just memory size. I will narrow it down to how big before barfing kills it but we are talking WAY less than the 4’x8’ full panels we have done for clients in 2d. We want to do full panel 2.5d, which is much more impressive.

Maybe the only approach here is to have ChiliPeppr sort of break the file into mini chunks in memory and only load one chunk at a time. You could do this manually in the short term, but of course it would be nice to have CP do it.

@jlauer I’m wondering if removing adding the gcode lines to the dom until after all the gcode has been parsed, and if it’s a large file, lazy load in to the table would work

Then again, I wouldn’t be surprised if it’s dying inside the initial regex… I’ll take a quick look tomorrow if I can get time

The Gcode widget only loads 100 lines at a time into the DOM, so it’s pretty fancy how it does it. The 3D viewer on the other hand loads all lines. It does, of course, load all lines into a Javascript array but that’s not really a problem from what I can tell.

@jlauer ok cool. Already done then

@Daniel_Chote@jlauer ​. There is a bug in the 3d renderer on both your workspaces where M commands that are on a line by themselves are repeated as “lastcommand” where a line is not prefixed with a G0/1 etc. I fixed this a week or so ago and I think I posted something about it but now don’t remember.

Either way it is an easy fix that you might want to implement.

5 posts were split to a new topic: Drag/Drop Out of Local Storage Space