Thanks again for your help Brandon, got the gcode issue fixed.

ox-help
ox-faq
ox
gplus
(Bob Martin) #1

Thanks again for your help Brandon, got the gcode issue fixed. Now comes the first run. I generated a simple circle, 76.19 mm, (3 inch dia.) in VCarve. Populated the gcode and loaded into BCNC. Everything zeroed on work piece, hit run and got an Alarm 2. (Soft limit alarm. G=code motion target exceeds machine travel.)
Any suggestion?

(Darrell n) #2

Do you have the proper values entered in GRBL Settings $130, $131, and $132?
Do you have soft limits enabled ($20)? Suggest disabling $20 and setting the proper values in $130-132. See if that fixes it.

MG

(Bob Martin) #3

@Hobby_Fab
My CNC is an 1000x750, the true measument of work area is X=565.348, Y=752.475. I entered the values into $130 and $131. with $20=1. Loaded a simple circle Gcode, Still get Alarm 2. Changed $20=1 to $20=0. $$ enter, I have tried rebooting with these setting, Z axis travel went to switch and I had to stop test due to no limit switch activation.
Before I start test I do zero all axes.

(Darrell n) #4

Are you hitting the reset in GRBL after changing the values? I find this necessary sometimes after making changes in the GRBL settings. You can hit the e-stop if equipped, use the small pushbutton on the arduino, or disconnect/reconnect.

MG

(Bob Martin) #5

@Hobby_Fab
@Darrell_n
Yes I do

(Darrell n) #6

Have a look at your G-code. You can manually view it in Notepad or Wordpad, just don’t use Word. Make sure the xyz numbers are not exceeding the size of your machine. Also, make sure that your units are consistent. IE, if you generated the g-code in inches, make sure your g-code sender is set to inches.

MG

(Bob Martin) #7

@Hobby_Fab
Haven’t figured how to attach file yet. Pics no problem.
I sent you an e-mail with Gcode attachment

(Bob Martin) #8

@Darrell_n
I have ran Gcode both in inches and mm. I have saved and changes to settings, re=booted even. At this point the only way to avoid Alarm 2 is to enter $20=0 followed by $$. after that Gcode will start but Z axes goes to the limit switch, I stop Gcode before it crashes. I changes $139 and $131 to 1470 both X,Y no change.

(Darrell n) #9

Your problem is in the G-code, as Hobby-Fab has shown above. You CANNOT run g-code in inches if your machine is set for mm or vice versa. Pick one and stick with it. You should only have to set $20 once in your life, not every time. And when I said reset, it is the Arduino you want to reset, rebooting your computer will do nothing.

MG

(Bob Martin) #10

@Hobby_Fab
Well after changing the G54 to 10mm, I have run my First Gcode.
Still some bugs to work out.
Can’t thank you guys enough.

(Bob Martin) #11

Spoke to soon, Lost all code after I homed. On G54 no up down in or out.

(Bob Martin) #12

All is great everything is working, two large dry runs and no problems.
Want to thank both of you for the support.