Stuck on control x

Hi I’m new ti cnc and new to the forum and new to forums in general. So I apologize if this isn’t posted in the right place. I bought a genmitsu 4030 PROver xl a couple weeks ago. And so far it has worked ok aside from user error. Today I connected to my computer turned on the control box and launched candle and in the console window it says control x. So I pressed reset, unlock, home, jog and all the other functions and nothing happens. I typed control x woth the keyboard nothing happens. I checked the com and baud they are correct. I turned the control box on and off several times nothing changes. I closed and launched candle several times nothing changes. I restarted my computer a couple times nothing changes. Im very frustrated and its probably something simple. What am I doing wrong? What do I need to do to get this machine moving again.

Please upload a screen shot of this.

Upon opening of candle this is what i see. No alarm for unlocking.

I think Candle prints this if the control board isn’t responding. (I haven’t encountered exactly this in my own use.)

If I’m right, $$ won’t work either. Do you get a parameter dump if you type $$ and send in the console?

For “turning things off and back on again” you might try this sequence:

  • turn off control box
  • reboot computer
  • turn on control box
  • start Candle

There’s not a lot of information on the sainsmart website about what controller they provided, just a warning not to update the firmware. :frowning:

You are correct. I did try $$ and nothing happens. Hopefully i dont need a new control board. I will try the sequence pf resarting and rebooting that you mentioned.

I doubt that the sequence will fix the problem; it’s just “shut it all down together before restarting” just to be sure. “Belt and suspenders” I guess…

Another possibility is that vibration knocked loose a connector inside the control box. Does the control box have a “warranty void if broken” sticker on it, or can you open it up without talking to their support folks?

If you don’t find any loose wires, you could also test with Universal Gcode Sender (UGS) and/or bCNC to see whether either of them can talk to the board. (I don’t know of any way that Candle would end up with broken configuration that wouldn’t be visible, but you could at least confirm.)

I have tried universal and a couple of others and I get no response from them either. Im not afraid of opening the bix but i hate to tear into something ive inly owned for 2 weeks. But then how difficult will it be to get sainsmart to send me a replacement.
Thank you for your time and effort. I believe it has help eliminate some possibilities. Hopefully I will get this figured out.

1 Like

Yeah, those were long shots; good to at least confirm it’s not Candle configuration.

I guess you could try using a different USB port on your computer as well, just in case the USB port you are using went bad?

I’d definitely start by looking for loose wires in the case. It’s often the easiest fix, and if you can reach support (don’t rule it out!) they might suggest the same thing.


Well I opened up the board and found a couple wires that may have been the culprit. After reconnecting everything it appears to be functioning. But now I have a new issue. When I start a new cut the spindle comes up to speed but as soon as it enters the wood it turns off and I have to reset and unlock everything. Then it will not go home. I have to jog the z up once, unlock it again, then jog the z all the way up. And proceed to send it home. What could be causing this?

There is a nearly 24,000 member facebook (yeah, I know, faceplant) group for Sainsmart and similar CNC machines including the 4030XL and it’s variants, that would be another place to look for help. And make sure that if you have the offline controller that either it or a USB cable are connected. Never both at the same time. Are there any messages in the log window you showed earlier with the [CTRL+X] in it? And can you show the whole screen, including the status that would be just above your previous screenshot, when it’s not responding properly. My first suspicion would be a power supply issue, double check that power cables, both mains and DC, are properly connected at both ends and verify that the outlet you’re using has power. Probably not, but always worth double checking with intermittents. And if you open the controller box again take before and after pics of any changes you make.

Unlike a lot of import machines Sainsmart actually has support and honors their warranty. With a 2 week old machine there shouldn’t be a issue. support at sainsmart dot com. They’re in China so there’s both a time and date difference but they usually respond fairly quickly. I probably wouldn’t mention opening the controller box :slight_smile:

1 Like

Can you be more specific? Did you by any chance take pictures?

To @Kirk_Yarina’s point, do any errors show up in the console when the spindle stops? If it has NC endstops (as it should) and one has an intermittent fault, the movement from the spindle touching the wood could be triggering the intermittent connection and registing as an endstop-hit fault.

Definitely do contact Sainsmart support!

No, all these 3018s use NO endstops unless they’ve been rewired. Way more chance for EMI to trip them that way. Sorry for the delay, OOT

Oh, that’s sad, but also as you point even more likely to trip. :frowning: