Still need some help finding out what's going on ...

Still need some help finding out what’s going on …
Here is what happens, it’s supposed to be 2 circles and one rectangle but their shapes are just fucked up and idk why the laser kind of stops cutting sometimes
Can you please help ^^’
Thank you

Lots wrong here…

Did you follow the earlier advice to do a complete alignment?

It seems that the mechs are struggling and that the optics do not stay in alignment across the beds area.

Tell us something about this machines configuration and the software you are using.

I detect (from video) 2 areas of problem:

The drive system is not running smoothly:
Potential causes:
…Belt alignment or tension
…Slipping pulleys on steppers
…Broken or worn belts/bearings
…Dirty or damaged gantry surfaces, wheels or bearings.
Check the gantry movement without poser by manually moving it and feeling for looseness, binding, grinding or lack of smooth motion.

The optical system is misaligned/damaged:
Potential causes:
…Reflections in the head caused by bad/misaligned or damaged lens
…Alignment changes at different bed positions caused by misaligned mirrors, and objective lens.
Complete alignment
Remove and inspect objective lens

@donkjr I checked the alignement, it is good, the mirrors and lens looks great too.
What do you mean by ‘check the gantry movement without poser’ ? I’m not used to the laser part terms ^^ what do you call the poser ? the gantry ?
Thanks in advance ^^

poser should have been = power :slight_smile:
The gantry is the x/y movable components of the machine.
We are trying to find something wrong with the mechanical drive system by manually moving it with power off.

Can you post the burned targets that you used when you did the alignment.

Hi ! It doesn’t seem to be a reflection problem anymore, I managed to coincide both up and down spot in the center of the 2nd mirror (i didn’t know that i could move the mirror to the right or th e left by moving the whole support so the two spots coincided at the extreme right of the mirror, thats probably what caused the reflection, but i still have trouble to find out what change the shape, it doesn’t seems to be a belt tension problem has i changed it and the problem doesn’t disappear, but i noticed some place on the y axis where the head seems to block (see picture) does it give you any sign to find where the problem is from ? Thank you ^^

The lines are where it seems to ‘block’ and i circled some spots on the rectangle cause it’s easier to see them on straight lines, those spots are where the laser blocks, it’s like if the machine has to make a really little loop (half a millimeter) and it shifts the whole drawing

Still do not know what the configuration of your machine is?

I am bothered by the whistling noise that is in the video any idea what that is?

Reading back through your posts this machine has had lots of mechanical problems so my guess is that the drive system still has something wrong with it. Why the laser comes on and off seems to be a separate problem. Lets see if we can rationalize the drive system first. My guess is that something in the drive is slipping.

Test #1
Lets reduce the test to something simple and see if that gives us a hint.
Lets draw a simple square and draw it both in the upper left and also in the middle of the engraving area.
Please take a video of that test and post it.

Kleinschnitz if by software you mean what i use on my ccomputer i use CorelLaser (sold with my k40) the controller is the more complete one, switch for light, switch for power, ±10 ±1 ±0,1 buttons, laser test button etc maybe you need a pic ?
For the test, i have to cut 2 square at the top left and in the center of the cutting area right ?

Yes cut two squares one in upper left and one in the center of the bed.

@donkjr I can’t post it in a comment, should I post it as a new post ?
it’s supposed to be 2 square of 30mm but it’s actually 2 rectangles of 3028mm for the top left one and 3028.5mm for the center one
What does it mean ?
Thank you for spending your tile on this problem, sorry if i take time before answering…

If you “reply” do you not get a camera icon to click on to link to a picture?
Alternately put it on a cloud somewhere and post the link…

It looks to me like the X axis is working correctly.
As the head makes the Y down move it whistles, moves and then gets a small X offset that is then corrected near the end of the upward Y stroke.
1.) Has the machine always whistled? Can you tell where it is coming from?
2.) Are you sure that the Y error is not in the source file?

I cannot run your file as I have a modified machine.

@Nedman you have a stock machine. Can you send @Manon_Joliton a 30x30 mm set of boxes like in the video above so we can see if the problem is in the software or mechs???

It has whistled since 3-4month, can’t tell why, seems to come from behind the machine or from the box in the right compartment (can’t tell how it’s called sorry >_<)
this ‘shifting’ problem happened to me 5month ago and I just had to change the mainboard name in the parameters in CorelLaser, do you want a pic of those parameters ?


Yes lets post a picture of those parameters.
I cannot help with them but I can find help within this community to insure they are right.

Please also post a picture of the box you think is making the whistle.

+HalfNormal can you help verify config for stock machine?

@donkjr @Manon_Joliton
I can help with the config parameters as well.

I’m using a current version of coreldraw and not the old stock version that comes with the machines, so I’m not sure how well it would work. Maybe I can export it as a Jpeg and he can import it in and see if that make a difference.

That little X jog is weird. I once had a problem with circles not quite matching up from beginning to end but that ended up being a belt tension issue. What output format are you using for cutting? What happens if you change the output format? Output formats are under “Coreldraw settings” and is listed as “Cutting Data”. Nominally it should be WMF. You could also try EMF or JPG.

Also, in case you didn’t already know, you can get rid of the double cutting by setting the cut line widths to 0.01mm or less. If the line widths are larger it cuts both sides of the line, hence the double cut.

The cutting data setting is WMF, here are my engraving/cutting properties, last time I had this kind of problem, I switched my mainboard from M1 to M2 and it worked, this time, I tried all the mainboard but the M2 is still the better (less worth) one

And this is where I think the noise come from, it seems to happens when the DEL lights on (so when the laser is working it’s logic…)

DEL lights? What is DEL.

So here is a possibility to consider:
…The Laser Power Supply (LPS) is arcing internally when the laser starts up.
…This arc is creating electrical noise that is causing movement errors in the controller …

Try this at night:
…open the right cabinet and with the lights in the room off and the cabinet open, run the job.
See if there is arcing (lightning) coming from inside the LPS?


An arching LPS is a common and frequent failure with these machines.

I meant LED (DEL is the french word sorry)
there is no lightning inside the right cabinet, the LPS is what i called the little box ?
Anyway, there is no light/lightning coming frol there