Steps per millimeter

My steppers X & Y only travel half of the requested input
I have worked out the steps per mm using the splendid josefprusa calculator which makes life easy.
My config file says 80 is the correct calculation which is based on a 200 step motor 1/16 microstepping which is set on the smoothieboard, belt pitch 2mm and a pully tooth count of 20 teeth.
All good but asking pronterface to move the X axis it moves 50mm for a 100mm request. Same for a 10mm request 5mm movement.
I have addressed the board with G Code directly, still only moves 50%.
I tried resending the config but with 160 steps per mm. Exactly the same. If I enter a M62 it reports X80 and Y80 even though my config is set to 160.
If I input an M62 X160 Y160 I get 100mm movement when I apply a 100mm request using direct input.
Have I missed something with perhaps my write to the config. Just one other silly question, there are two buttons on the board. Which is the reset button and what is the other one for.

Smoothieboard v1.1 is 1/32 microstepping, not 1/16. The prusa calculator was written like in the first months of the Smoothie project, which was about 8 years ago. It’s just not up do date.

1 Like

OK that makes it 160. Why when I change the config to 160, I get the same result. Thanks for the quick reply by the way. I think his calculator I have just looked at is much later and does allow for what it calls “Crazy smoothieBoard 1/32 u step” I’ve used that but I can’t seem to get the board to recognise 160.

( sorry for the delay, I had reflexively answered the email notification I received about this post, and it just now told me it couldn’t deliver it. it’s my fault I should have remembered you can’t do the “answer in line” thing some mailing lists/forums allow. actually answered this 2 days ago :slight_smile: ). So:

Do other config values do what they are supposed to do when you change them?

This could be SD card corruption. Try saving your config and firmware.cur on your PC, very safe, then format the SD card using a SD card reader on your computer, put back the two files on it, insert into Smoothieboard, and test, then tell us what that did.


I did take the SD card out, stuck it in my pc and deleted the config and then copied across a new downloaded config file with the new steps/mm set to 160. I did a proper eject and restarted smoothie with the new file.
It was still only driving at 50%. I will get it back out tomorrow and format the card like you say and put a new config and firmware file. Then try again. Do I need to press one or both of the little resets on the board. I can’t find any information about what they do. I’ve been through the smoothie guide so many times and haven’t found any info on them at all.

Just unplug the board, wait for the leds to go out, plug back in.

I removed the sd card from the board as you suggested and put it in my pc drive. Copied across the Config and firmware files to the PC. Formatted the sd card. Copied back those two files. Did a safety eject. Put it back in the smoothieboard. Hey presto just like magic it has restored the size to 100%. Really many thanks for that help. I guess that’s me done now and I can press on with the printer build.


Glad you got it to work :slight_smile: