SPJS version 1.86 binaries now live for Linux and Windows.

gplus
(JOHN LAUER) #1

SPJS version 1.86 binaries now live for Linux and Windows. If anyone can compile for Mac for me that would be helpful. http://chilipeppr.com/downloads/v1.86/

(Brian Cross) #2

Very cool! Will try it out tonight!

(carl j mcgrath) #3

John: I downloaded the Linux amd64 build from github, unpacked and started up. The console log looks normal. CP connects, the Serial Port Widget displays ver 1.86, shows my tinyG available.
Clicking the tinyG checbox (with tinyG buffer selected) seems to crash - checkbox stays checked (black) for perhaps 2-3 seconds, then the checkbox goes empty.
I see no activity in the Serial Port Console
tinyG is running FW=440.20
Any suggested diagnostic steps?

(JOHN LAUER) #4

Can you send me a screenshot?

(carl j mcgrath) #5

Guess I need the embed pictures tutorial
https://goo.gl/photos/XEztJS7MsaGKQWgQ9

(carl j mcgrath) #6

Here is the full CP window
Ah so, I needed a ‘sharable’ link
https://goo.gl/photos/iBjgXGFPQ9N2fokr5

(JOHN LAUER) #7

Why don’t you just email them? That link didn’t work either.

(carl j mcgrath) #8

@jlauer Just did

(carl j mcgrath) #9

For those watching here.
I downloaded and initialized (did not fully exercise) SPJS 1.86 running on Win10_amd64 (in a virtual machine, actually).
There appears to be an issue with the Linux_amd64 build. On my preferred platform, openSUSE 13.2_64, the SPJS widget correctly displays the FTDI Port , but clicking the check box to select my port (/dev/ttyUSB0) throws an error and the port closes within 2-3 seconds. Error messages visible in the SPJS console.
This may affect RasPi builds or other Linux platforms as well.
Give it a try and post results.
My issue still under investigation.

(Brian Cross) #10

I downloaded and ran the AMD64 version last night on Xubuntu. It ran fine and talked to the machine without any issues.

(carl j mcgrath) #11

@Brian_Cross thanks for info, Brian. That will help narrow the search. What Kernel is your Xubuntu system running? Most ftdi support seems to be in-kernel. Mine is 3.16.7-24

(JOHN LAUER) #12

I just tested out on a Raspberry Pi 2 and 1.86 works great.

(carl j mcgrath) #13

John, when GO builds the binaries, does it use GO libraries (e.g. for ftdi), or does it draw from the system libraries? When I get a chance(busy today), I’ll try to build on my opeSUSE system and see if that makes a difference.

(Brian Cross) #14

@cmcgrath5035 ​ I’ll check the kernel version after work if you still need the info by then.

(JOHN LAUER) #15

Go does not need any of that. Opening a serial port is like opening a file. You just open it and then read/write to it.

(carl j mcgrath) #16

So I think that says GO uses the underlying OS resources to manage the dirty details of the particular file or port. I would expect that
So Brian , it would be helpful to know your Kernel and perhaps what ftdi libraries Xubuntu has loaded. My openSUSE has libftdi1 0.20 loaded.
No rush, I am otherwise engaged today

(Brian Cross) #17

My kernel version is 3.19.0-30-generic. How do I check the ftdi library version? I tried the following:

ldconfig -p | grep libftdi

and got:

libftdi.so.1

(carl j mcgrath) #18

Thanks Brian. You are obviously a bit ahead of my openSUSE; we are due for a major rev next month, perhaps that will help.

I am totally unfamiliar with Xubuntu and it’s package manager, the version of libftdi1 would be available there.
All libftdi1 versions provide libftdi.so.1.

I did, as a quick test, load version 1.2 of libftdi1, but no change in the eror messages I get from SPJS. Perhaps the issue is in the Kernel portion of the driver.

(Brian Cross) #19

Oh right, I forgot about the package manager. I’ll check there as well. Is openSUSE based on Red Hat? I tried it out years ago before settling on Debian and then *buntu for my machines.

(JOHN LAUER) #20

Carl, does version 1.80 work ok for you? The serial library I’m using for Go is identical from 1.80 to 1.86 so if 1.80 works fine for you then it’s likely something in my code and not you.