[Solidoodle] My kind of luck... I just got it today.

[Solidoodle] My kind of luck…
I just got it today.
Installed Arduino Drivers
Installed Python
Installed PySeriel
Installed Python Unicode Suppprt
Installed Solidoodle software (pronterface and skeinforge)
Now the Pronterface software is all greyed out…

pronterface doesn’t consider itself connected until it gets a valid response to M105 (report temperature)

you may simply need to choose a different baud rate, 115200 and 250000 are common. Also check that you’re feeding it the correct port

Changing the Baud from 115200 to 250000 did it! I never touched it, because I wasn’t sure how USB 2 translated into baud, lol

USB doesn’t care about baud. there’s no such thing in USB-land, it’s simply a number that the host passes to the device. However, the data lines between the usb-serial chip and the main chip on your arduino are async ttl which does require the baud rate. The usb-serial chip uses the number passed over USB to generate appropriate clocks, and hopes that the main chip is talking the same language. If they’re not, well… you get nothing or gibberish.

If the usb ran directly into the main processor, baud would be completely irrelevant. This is the case on Smoothie for example, which accepts but otherwise completely ignores baud rate change requests. We use USB’s built-in flow control to manage the flow of data- there’s no chance of an overrun in this arrangement.

That makes sense, thanks!

OK, new problem…
Now the Pronterface software can move the head and bed around and it seems to have a real-time reading of the temperature. But when I go to print, it says “Printer stopped deu to errors. Fix the error and use M999 to restart!. (Temperature is reset. Set it before restarting)” about 2k times and does nothing. I tried setting it to 230 (what pronterface said is default for ABS) and 190. Still no movement at all, any ideaas?

When you set the temperature, make sure that you’re also monitoring the printer. There is a small check box in the middle at the top that says monitor printer. This will let you know if your printer is heating up. If your G code doesn’t include temperature codes then your printer won’t start printing because it doesn’t want to try to print if it can’t extrude.

I’m assuming of course that you’ve done a power cycle.

That makes sense, so, um, what temp should it be 230? Or?

Oh, and how long after it is done printing can I handle the printout? I don’t know how long it takes to cool/set…

It should be 200 for extruder and 100 for heat bed.
After finishing, you will see it at the console on the right side, Print ended at :… Set heat bed temp to about 60-70. It will be easier to take the product out.

Thanks Dat!

Oh, and how do I get it off of the hot bed without damaging the bed or the printout?

I use a small paper knife. But at low temperatur (on heat bed), you can take the printout by hand (with no effort).
PS: I suppose, you have kapton tape on the heat bed? Then don’t worry about scratching it. After a month or more, remove it and get a piece of glass instead.

@Dave_M1 the part should be “set” immediately when the print is finished. If a layer is not hardened or at least well on its way when the next one goes over the top, you get curling and other undesirable distortions.

If you’re printing PLA, you should be able to just pull the part off the bed immediately, with ABS you’re better off letting the bed cool down first, many report that the parts pop off by themselves when the bed cools.

If you’re curious, I have never burnt myself with a printed part, even pulling ABS parts off the instant they’re finished.

Check your thermistor wiring carefully. If the firmware receives even a single bad reading, it will stop the print and spam that M999 message. This is ultimately for the safety of your printer- without the thermistor behaving, it could destroy your hot-end! A few failed prints are vastly preferable to having to replace the hot-end or worse

Tanks Dat, maybe i’ll print a spatula to use on my printer :open_mouth:

Thanks Triff,
Wasn’t worried about burning myself, just worried about damaging the printout!

Cool idea, but don’t forget setting the heat bed temp. down first. Otherwise, you are gonna have a hard time with it :smiley:

Thanks Dat, I sure appreciate you helping out a newbie!

You’re welcome, I’m just a newbie, too. Btw, merry christmas.