So today I figured out why all of my svg's were scaling wrong when

So today I figured out why all of my svg’s were scaling wrong when imported. I mistook the setting in LAserWeb4 as DPI when for svg it is apparently px per in. If anyone is also been experiencing this swap the value from 96 to 37.795276 and it should scale right.

+Peter van der Walt nope, it’s not. px is an artificial unit that’s not a dot or a pixel. It was something software developers came up with to trick short-sighted designers back in the early 2000’s who kept demanding pixel-level tweaking in their CSS layouts. The trick is so affective that people keep falling for it.

We handle metric/imperial issues for SVG, so something funny is going on. @Domm434 are you using Corel?

nope inkscape 0.92.1 and always have had to re-size the drawing. turns out the above number was still off, but manually isn’t exactly hard to do.

Did you create a fresh SVG or edit an old one? Inkscape preserves funny px-per-inch values in old files (e.g. from Corel)

fresh one

looks like the magic number was 25.4 pxpi to get perfect scaling (which is also how many mm per inch, go figure!)

I just upgraded Inkscape to try this. I really want to strangle those developers. It defaulted to 1 px-per-mm after years of them promising they’ll move to 96 px-per-inch to be compatible with what web browsers settled on for CSS.

Hello, First time posting. Just started with lasers/smoothie.
Had the same issues, I put it down to a xml setting called viewbox.
You can save as optimised SVG and tick the enable viewboxing button. Although I am not expert.

They should pop up a dialog the first time you run InkScape:
“Do you want to use our settings or a more sane one that the rest of the world uses?”

@Mike_R Thanks for that tip! Now my SVG’s import with the correct size in LW4!