So I've pretty much finished the Maker's Kit upgrade on my Printrbot  Simple,

So I’ve pretty much finished the Maker’s Kit upgrade on my @Printrbot Simple, and I’m confused. Doesn’t the placement of the new Y stop require you reverse the direction of the Y-axis now? So origin would be (looking down on the build plate) the upper left corner, instead of the upper right corner? And doesn’t that now make the coordinate system a non-right-hand-rule one?

Finished mine too, just stick to the guide and reverse the motor :slight_smile:

Yeah, that was easy enough - already did it. I’m just a picky mechanical engineer and it irks me to have to recalibrate my visualization of the print bed. :slight_smile:


The Auto leveling is pretty disturbing the first time and i am not 100 % sure if i like a moving z while printing

@Nils_Hitze Yeah, I’m just about to do the first auto-levelling myself - just have to finish calibrating and resetting the print bed size first. I agree that having the Z run continuously promises to be a bit of a kludge, but I suppose you don’t have to use it - you could just level out the bed manually and call it good enough.

Huh… auto-level doesn’t do anything. When I send the G29 command, I just get an error message:
1:57:02 PM: Unknown option wipe
1:57:02 PM: Unknown option use_firmware_retraction
1:57:40 PM: Printjob finished at Jun 15, 2014, 1:57:40 PM NDT

I just ran the firmware updater but it doesn’t seem to have changed the firmware version:

1:59:43 PM: FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:Printrbot EXTRUDER_COUNT:3

Is there some other firmware version I need to apply instead?

Ah - never mind. Found it and applying it now.

Let us know how it works. Odd that you wouldn’t just auto level at the start of your print session and then have the probe disengage. But I guess if it is slightly above the bottom of the print nozzle it doesn’t matter

Huh… new firmware seems to have broken compatibility with Repetier. The status line says “n commands waiting” and just stacks up commands. Hitting reset clears the waiting commands, but also disconnects. Reconnecting generates new commands and it just hangs. Google search indicates there’s a check box to clear in the Windows version, but no such option in the OSX version. :frowning:


Sigh… The wild and wooly world of DIY. I tried an older firmware revision and got back connectivity, plus it claims to have bed levelling - but now the Y-axis homes in the wrong direction. I don’t mean the axis has the wrong polarity, I mean it “homes” by incrementing the Y. Just the Y - X works normally. SMH…

Double ugh. I say send a note to tech support. The upgrade should be better documented than that - it’s a specific set of variables

Easier to ask @Brook_Drumm directly

My advice would be try tech support first, if you get impatient with that escalate to Brook directly. Let’s try to keep his time mostly not occupied with tech support stuff if it isn’t necessary :slight_smile:

Checked the site forums and it looks like this is a known issue. :frowning:

Now on top of everything else, my hot end is jammed up! It never rains but it pours. Hey, @Nathan_Ryan , got a spare hot end I can steal?

It’s a SeeMeCNC hotend, and its a Bowden. :smiley:

But, yah!

Is it the nozzle? I think I have extra nozzles

Yeah, actually, it is the nozzle. I was thinking I should buy a couple spares to keep on hand…

hit it with a blowtorch

Yeah, I thought of that. Believe it or not, I appear to be currently out of blowtorches. Not sure how that happened… But I intend to rectify that situation today!