So, if anyone wants to give my WebUI addon for Cura a test drive

So, if anyone wants to give my WebUI addon for Cura a test drive (I’m looking at you, @Nils_Hitze ;)) I just added a couple of hints to https://github.com/foosel/Cura#webui on how to get this stuff to run. I also have a working windows setup.exe including a webui startup shortcut, but that’s still having the issue of not stopping the server when closing the command window, so you’ll have to take that with a grain of salt (and be prepared to kill the running python.exe process via the task manager once you are done): http://db.tt/gjaR1NMd

I also revamped the gcode-upload-feature. On Windows, the uploaded files are now stored in %APPDATA%/Cura/uploads, on *nix in ~/.cura/uploads and on MacOSX it’s supposed to go to ~/Library/Application Support/Cura/uploads (I hope, can’t test it). The server should also check the file extension and only allow .gcode files to be uploaded, and sanitize the filename from the client to stop any stupid things from happening, but no guarantees on that – if that thing breaks something, I’m not responsible :wink:

I successfully printed some stuff this afternoon, with the WebUI running on my raspberry-pi and the printer in another room, starting and monitoring the whole thing via my Android tablet while relaxing on the couch, so at least I’m quite satisfied with the results so far :wink:

This is very cool, I’ll be giving it a try soon. Did you have any luck running it on a Raspberry Pi yet? I’d love to give that a try!

Yeah, that worked after cloning the repo, installing first pip and then the dependencies via pip install -r requirements.py, and then starting the app via python -m Cura.cura -w (if i remember correctly). Loading gcode for printing took a bit longer than comfortable though (as i dont have a progress indicator for that yet, only for the initial upload)

I’ll have to give it a shot. What printer/firmware are you using this with?

Are we looking at the possibility of running a 3D printer from the R-Pi?

@Jason_Gullickson An ultimaker with marlin at 115200 baud.

@Gabriel_Petrut we are looking at the possibility of communicating with a 3d printer via a raspi as the host pc, not the raspi as an replacement for ramps

Awesome! I’ll definitely give this a try then soon (running marlin as well); maybe even tonight if the caffeine holds out :wink:

@Jason_Gullickson great :slight_smile: hope it works for you, will have to catch some sleep now (it’s 2am here), so no live support :wink:

Basically what I’m interested in is an all-in-one 3D printer-scanner-copier. Is that possible with a R-Pi or it needs a notebook to do all the processing?

R-Pi won’t replace the printer’s electronics (ArduinoMega + RAMPS in this case) because it doesn’t have the GPIO necessary The other thing that might be tough on the Pi is slicing, since it taxes even modern desktop machines to some extent. That said, if you didn’t mind the wait, you could do it on the Pi.

It’s worth pointing out that the RAMPS board can be equipped with an SD card slot and can print on it’s own from gcode files on an SD card with no host computer attached, but this option that @Gina_Haussge has put together is cool because you can manage and monitor the printer across the network as well

Thanks, I’ll start a new thread so we can continue discussing this.

@Gina_Haussge I know you were calling it a night, but if you happen to be around, let me know how you set the serial port & baud in Cura (the web UI is coming up but since I’ve never used it before I just need to know how to tell it where my printer is :slight_smile:

looks cool. still building a new one… Will try out when it’s ready

Nevermind, figured out the port setup (or rather, the fact that there is none :slight_smile:

Ok got this working (first time using Cura) and let me say that it’s awesome @Gina_Haussge ! I’m looking forward to untethering my Reprap now and hauling it around more often. Are you planning to expose more of the Cura functionality through the web interface, perhaps even slicing at some point?

Thanks for building this, it’s very very cool.

@Jason_Gullickson Great that it’s working for you! :smiley: Sorry I forgot to mention the serial port thing, that’s still on my todo list (might move the connect button to a new accordion with some more info).

I thought about more features, should be possible. Currently webcam support would be the next thing on the list, but only after the printing stuff gets some more love (speed settings are still missing, jog controls are very basic, and I need to think about how to provide some more feedback for loading a gcode file)

Still got some more vacation time these holidays and having an awful lot of fun, so let’s see :wink:

Super cool! Hope to get this running very soon. It should work on an OSX host as well, right?

It should, I had no way to test it though, only got windows and Linux here

Hey @Gina_Haussge , great work so far. There is certainly a delay between the point where the upload progress bar completes and the controller lets you start the print which confused me a bit (took almost 15 minutes before it was responsive again). I could see that Python was churning so I figured it was doing something with the uploaded file but I have no idea what exactly :slight_smile: Some feedback there would be good.

Otherwise it seems to work well, the connection to the printer times out after about 10 minutes of it sitting idle but that could be on the firmware side as well, not sure, but not big deal you just “reconnect”. Wiring-up the jog controls would be nice (instead of having to remember the gcode to send the yaxis home so I can pluck out the part) but overall it’s pretty sweet so far and I look forward to updates!

Hm… The Jog controls actually should be wired up, at least they worked on my end when I tested them yesterday… will have to look into that tomorrow. Will also take a look at the timeout, that’s a new one, but I’ve been restarting the connection so often during development that I probably simply didn’t notice…

About the gcode-loading-feedback, yes, that’s definitely on the top of my todo list right now – I’ll continue working on it tomorrow, today I had to take a break for that relative-visiting-mumbo-jumbo :wink: 15min sounds like a big file, how many lines are we talking?

Btw, which printer are you using this on?