So I just got my inductive sensor in and it seems to be always

So I just got my inductive sensor in and it seems to be always showing TRIGGERED. Anyone know why? I can have it sense a piece of metal and it lights up but doesnt change its status. I have tried it on all endstop ports.

The other problem is that my ramps always shows z_min TRIGGERED when there is or isnt a switch connected. Do you guys think that I have a short somewhere on the board that is causing this? It doesnt care that I have a switch connected nor open or closed. Thanks to all!

I don’t think it worked beforehand either. I tried the sensor in the x axis port and it shows always triggered when I plugged it in (doesn’t care if it senses metal which is an issue). But when I unplug it in that port the port goes back to open. The z never wants to change. And I bought the sensor but it didn’t have a sticker but based on the model I think it is normally open. But it shouldn’t matter as I put a piece of metal up to it and the light triggered but the M119 status didn’t change.

I don’t think anything is new in the firmware aside from commenting out min endstop pull-ups as @Thomas_Sanladerer has a guide that said to do so. I followed his steps.

how have you hooked it up?

Just as described above. I plugged it in like a normal endstop would except I used the power as well.

There are different types of sensors and the method to connect one varies by type. They are either normally open or closed and either connect to the source or sink.

@Wylie_Hilliard could you explain what you mean by sink?

In this case, source is roughly equivalent to positive, and sink is roughly equivalent to negative/ground.
You should probably watch @Thomas_Sanladerer 's video on inductive sensors (they don’t just hook up like switches). Also, you’ll need to know if your sensor is normally open (NO) or normally closed (NC).

@Carlton_Dodd that’s the video that I set it up with. I bought the same model that he used. I might just bite the bullet and buy one hooked up from Printrbot but I like being diy.

Did you set up the voltage divider?

@Carlton_Dodd yes I had to set up a series of resistors for the 15kohm and then used a 10kohm. Just like how he did it in the video.

Then your setup may be set for NO and the firmware for NC (or vice versa). You’re going to have to invert your Z endstop in firmware.

@Carlton_Dodd Ok I will try that. But wouldn’t it still work if I held a piece of metal up to it? Such as the inductive sensor would then show open?

@Carlton_Dodd I tried and it didn’t work. It won’t change what it originally reads wish the inductive sensor.

Well, I’m lost without having hands on. Sorry.

@Carlton_Dodd it’s ok I know what you mean. But wouldn’t having the 10kohm resistor from the ground to the signal create a closed circuit no matter if the switch is triggered or not?

Are you using a pb or reprap?

Sink sensors connect the signal wire to the ground when the switch is closed. Source sensors connect the signal wire to the source voltage when the switch is closed.
You can use a voltmeter to determine which type of switch you have and if your voltage divider is working correctly.

@Wylie_Hilliard so would I check for continuity between two wires? How would I check using my voltmeter?

And @James_Malenko I am using a reprap with a RAMPS 1.4