So I am almost ready to start printing.

So I am almost ready to start printing. my x and Z steppers are working with pronterface. My y axis is fine and if I plug my z or x steppers into my y plug, they work. Any ideas? Video shows the problem in a bit more detail. Thanks for any help!

What firmware are you running? Sometimes if the mm/min is off in the firmware it will cause the motors to stall.

I’m using the stock firmware that came on the 1249P. I can’t get my arduino environment to talk to it either to flash something new.

Are your driver currents adjusted properly?

wow do I feel like a noob. What does that mean? Are those the pots on the ramps modules?

Yes make sure the pots on the ramps module are adjusted.

You’ve a sangulinololu?

If the voltage on the pot on the non-working axis is lower than the voltage on the pot on the working axes, you might try adjusting the pot up a bit. On the other hand, if the volts are the same, then the currents should be the same & I’m not sure what’s wrong. My machine’s different than yours, but I’ve got my Pololus tuned to Vref=0.28V for 0.7A peak current. Which, for my 1A NEMA17s is 70% of stepper rating, for 70% of 1400 g-cm torque and 50% of motor heating.

I adjusted the posts on the x and z. At the top end of the pot, the motors started to shutter with no input, but they did move the x axis very jerky like, still doesn’t match how the y moves. They also got very hot quickly.

The cut out if they overtemperature. Set up for half-stepping, calculate the right volts for 0.707 of your motors’s current rating & tune them for that. I wasted a stepper by overdriving it. (You don’t actually need to set half-stepping to set the reference voltage, but you do if you want to measure the amps directly.)

Have you tightened well the screws of the pulleys?. That noise is like the motor is working and the pulley slipping.

By the way. You NEED to be able to to upload updated firmware, as you wil have to calibrate your steps/mm and other stuff.

And take care of adjusting the pots before using the drivers, they can easily be ruined otherwise.

If you’re using a sanguinololu then you need the boards.txt file to get your arduino environment talking to it. Also make sure to add your user to the “dialout” group in Linux to get access to /dev/acmtty*

Take a look here:

@Alberto_Valero_Gomez I have successfully uploaded new firmware with the link you provided. Thank you! The X and Z still do not move.

I swapped out the ramp on the y axis to the x axis slot and it moved the x axis motor, but not smoothly, still very jerky. are these symptoms of calibration?

The words on the video confuse me. Y should move the bed in and out, and X should move the extruder back and forth, and Z should move the X carriage up and down.

Is your problem that the the only port that seems to drive any of the axes is the port labelled y on the sanguino? All of the axes work as expected with the Y port?

If both are true, I’d think your steppers and hardware are fine, and look to the drivers. I’d set the pot voltage on the non-working ports to be the same as the working port & try again.

Calibration as in wrongs steps/mm, shouldn’t cause non-smoothness, but calibration as in max feeds too fast may cause slow stepping as things go faster than interrupts can handle them. If that’s the problem, then slowing down the feedrate should fix it. If you are using 3000mm/min for testing, knock it down to 300mm/min or 30mm/min.

Perhaps I have it backwards. I call the plate the x, and the extruder is on the y. I’ve tried tweaking the pots to no avail.

Maybe try slower speeds.

Type M501 into the pronterface command line then paste the results here.

“SENDING:M501” nothing else. Should it take a while?

No, should be instantaneous, you sure you are connected to the printer now?

Actually, what firmware is this?