So here I go again, got my rapid slowed down that's obviously not it.

So here I go again, got my rapid slowed down that’s obviously not it. I am running the machine in my garage in Vegas in July/August Could the heat be having an adverse effect on it. In the video I show how it screwed up the same way twice, with a file I ran before that with no problem. So frustrated!


How hot do your stepper drivers get? Is it possible they are doing heat shutdown and skipping steps and that’s why you sort of see random behavior?

Your missing steps…slow the jerk down or a little wd40 on the x axis lead screw.

it’s a hot garage, I usually open the door some and run the swamp cooler but I didn’t today.

Looking at pics of ox. No lead screw,OK. Measure the error…does it match a tooth on the belt? …the design looks as though the belt does not wrap the pulley that much? As though it’s skipping one belt notch on certain moves.

Did you check for backlash with a dial indicator?

Is the milling job always messed up around the same X or Y area? Does milling in a different area work better/worse?

That’s a good question Nate I haven’t noticed. No on the dial indicator, gotta get one of those. The error is sporadic cut 6, 3 will good and in a random order.

Another weird thing is the other parts I cut have no problems only these!!

I know it’s been brought up before but how are you tensioning your belts? They need to be pretty tight.

I picked up a dial indicator for $20 a while ago.

Dial indicator? I just strummed my belts like a guitar string and made sure they sounded the same. Make them too tight and they will stretch to a different tooth spacing than the pulley and cause trouble.

Let’s go old school… What is the order of cutting operations? Are you milling the holes before the outer profile or vice versa? Could be the stock is moving or being pushed around if the outer profile is cut first. Is the stock flat? How much does it vary in thickness? 5-10% variation in thickness or other properties can cause machining issues. Have you switched materials to test that? Can you put a pen in the collet and run the toolpath at 10% of program feedrate on a piece of paper glued to cardboard?

I would probably try it cut the parts in phases. Half depth inner, final depth inner, half depth outer, final depth outer. I would probably try to do all the outer cuts of all parts last. That means setting up the gcode to have 6 parts if you are cutting 6 parts.
Is that carbon fiber mesh? The texture of the material looks odd.

It is carbon fiber

did you ever try slowing the jerk down?

@Steven_O_Neill what if it was not a matter of the tool moving, but instead a matter of the carbon fiber moving? Is the carbon fiber already epoxies or is it loose or glued to something?

@Steven_O_Neill So you are saying that at one point it did it right? Are those files using arcs? What firmware is on your TinyG. I know that the new edge posted fixed some issues in arc code. While I am not positive that this is, in fact I doubt it is if it “worked” once. Its still something I thought I would mention. It just so happens I am in vegas this week. Staying at the @Mandalay_Bay_Resort Also I am a FPV flyer too so I would like to see your final design on your drone. Is it a 250mm?

Of course… If the stock can move you are going to get this problem. It’s machining 101… Double sticky tape the stock onto a non flexible back… Like a piece of flat aluminum. The heat in Nevada might have an effect but unless you take the other variables out, you will not see the machine ‘noise’.

I am starting to think that simple double sided tape to attach it to something on one side is not enough. I am starting to think that he needs to repeat the process for the other side. I think his carbon fibers may be yanking during the cuts.

I have .14 and it says it recommends i update to .16 As far the material moving goes, that’s not happening. I pinch it down everywhere with screws. Sometimes it cuts perfect and the next two times it’ll screw up then back to good again, totally sporadic but I can cut arms all day with no problems. Could it be the chassis file has too many points to process compared to the simpler arms? Should I remove as many points as possible in AI?