so.... been away from my machine for nearly 5 months (finally have my shop

gplus
(Colleen McGuire) #1

so… been away from my machine for nearly 5 months (finally have my shop in order after a big move :slight_smile: )… and natually I wanted to update my tinyg … ok but now I’m stumped … I can’t seem to get my motors mapped correctly… The settings say they are mapped to the correct axes but when I go to jog… only the x axis seems to work… the others have the motor 1 indicator light going on rather than the correct motor… Any thoughts on what I’m missing here?

These are my settings:

(Alex Lee) #2

@Colleen_McGuire I compared your motor mappings to mine and they look fine to me.

I think I’ve seen this before, I had connected my tinyg to Chilipeppr using the grbl option instead of the tinyg.

Does the X axis move when trying to jog the other axis’?

(Colleen McGuire) #3

Hmmm not sure how I could be using grbl option… I’m definitely in tinyg workspace and settings come back w ‘tinyg ok’ But no … the other axes don’t move … Slight power sound but only the motor 1 seems to be getting power as indicated by green led

(Alex Lee) #4

@Colleen_McGuire In the TinyG workspace (or Grbl) there’s a drop down where you can choose the type of board before ticking the checkbox. It was a bit far fetched, but you never know…

What version of the Serial Port JSON server are you using? Are you running the latest version?

(Colleen McGuire) #5

@Alex_Lee I’m using the most current version I believe… Downloaded today

(Frank Graffagnino) #6

Maybe take a video and post it here. Might be the quickest way.

(carl j mcgrath) #7

You have the 4 motor drivers mapped to the X,Y,Z and A axis. Is that really what you want? What machine is this? I am guessing a NEMA23 ShapeOko-like machine based on some of your parameters. If dual Y motors, you have them both wired to motor2 driver?
Did you use SPJS to do the tinyG FW update?
What did you use to make your configuration changes (SPJS Serial Console, configuretinyG widget, other,…)?

If, by chance, you are mzmacky over at the tinyG Forum, https://www.synthetos.com/topics/motors-not-mapping-correctly-after-update/ , chose one or the other to continue; the problem description sounds very similar.

Actually, this forum tool, https://groups.google.com/forum/#!forum/chilipeppr, might be the best for this discussion as it is easier to post and refer to files, etc.

(Colleen McGuire) #8

Sorry… didn’t mean to double dip…

you’re correct… Nema23 on Shapeoko2 - I have no A axis… only put the settings in because it was default to motor 2 and I didn’t know if that would throw a conflict…Updated using the tinyg-updater with settings in the console… the file above is the $$ dump…

I might have it running now but I’ll be darned if I understand why… I loaded build 440.19 then reloaded 440.20 again… changed the settings for the motors to match the file above… it seems to be jogging fine now… need to tweak it more and test a gcode file …but I sure do wish I understood why it didn’t take the first time… oy. Thanks for taking a look.

(carl j mcgrath) #9

No problem ‘double dip’, just making sure we were working same issue.
Do you have both Y motors wired to the motor 2 driver?
If you have no A axis, why not connect to separate drivers?
It will work with both Ys on one, but you are not getting as much Y drive torque that way.

No good answer as to why your first setting of parameters failed if by Serial Console (one at a time).
Every time you load or reload FW, EEPROM gets wiped and re-initialized.
I do suggest not using the configuretinyG widget, it has been misbehaving for some folks.
Best way is to enter parameter changes is one at a time, in mm mode, via serial console command interface.

You see to be up and running; good luck