Smoothieware PWM variation during acceleration

Hi,

I’ve build a 50W CO2 Laser CNC with smoothieware on SKR v1.4 board.

I’m at the optimization step of my system and am trying to search the maximum acceleration with the less vibrations.

My problem is that it look like Smoothieware is ramping the laser PWM during the acceleration instead of putting directly expected PWM value. (the same system as M3/M4 command on GRBL).
unfortunately when acceleration is too low, the ramp of the PWM is too low and there is unburned portion on my cut.

Is there a way to adjust the pwm ramp or to disable it?

Best regards

vincent

The PWM is kept proportional to the speed so that the amount of power per distance stays constant. It’s the first time ever I’ve heard somebody request it be disabled.
You can’t technically disable it, but I guess if you used the ttl pin instead of the pwm pin, that would keep the power constant (no pwm) while still turning on/off at the right times. Would that work? If not I’m affraid you’ll need to edit some code (likely just one line).

1 Like