Smoothieware halt on boot or reset (and 2 other issues)

I installed an Azteeg X5 Mini Wifi onto my OpenBeam Kossel Pro 3D printer (Delta). It seems to be working but with a few issues.

  1. When I turn on my machine it halts (red Halt LED blinks quickly). LED 4 is solid, 3 and 2 blink, and 1 is solid. I can get out of it by issuing the M999 command on my machine but I’d like to resolve the issue causing the Fault. After issuing M999 the halt light turns off but LEDs 3 and 2 blink back and forth.

  2. My Viki2 Display does not show anything on the screen it lights up, blue LED works and turns red when the hot end heats up. But no text on the screen.

  3. I also swapped out the OpenBeam hot end for an E3d V6. Unfortunately what I’m finding is my hot end will not reach the target temperature. For example if I set the temp to 230 it will only reach about 202. I’ve run PID tuning a couple of times and updated the values but it hasn’t made any difference. I’ve also tried increasing some of the PID constants but that didn’t work either.

I’m using firmware-latest.bin from github (here). Version is f27f53d on May 6.

I can provide my config.txt file if needed (will need help on how to upload that).

Appreciate any help from this forum.

Connect with pronterface and look at the messages to see what is triggering the halt state.

Ok. I downloaded Pronterface/Printrun but I’m not sure how to determine what is causing the halt state. When I first power on or reset and connect with Pronterface I don’t get any logs in the console. If I try to enter a command (e.g. Home), it just says “Print paused at: 19:56:27”. From boot or reset I’ve got nothing until I enter M999. Then I can home and do other normal things, it just has to have that command first.

Turns out the Baud rate on the USB connection was the Halt culprit. Changed config file and MatterControl from 250000 to 115200 and that issue is now fixed. Viki2 still not working. Will continue troubleshooting.