Smoothieboard not moving motors correctly

Hi, we tried to modify our k40 with a smoothieboard 5 v1.1. We connected the steppers accordingly to the guide (AABB). We calculated the steps per mm with an online calculator. When we connect the board I am able to move the X(alpha) motor left and right but with A LOT of vibrating and it also gets hot. When I try to home it it moves to the right and stops at around the middle (endstop is on the left) even tho when I press X- and X+ its the right direction. When I try to move the other motor it stutters and doesn‘t move. I tried changing the steps per mm but it doesnt seem to change anything?
When connecting the M2-Nano again everything works fine.

Any help would be appreciated.

Post your configuration file.
Also, post pictures of your motor to smoothie wiring.

Here is my config:
Also the motors don’t have anything writte non (like model nr.). I measured them and came to conclusion they should have 1A. Also tried setting the config to 0.5A, didn’t change any behavior.

Also I am not at the laser at the moment but this is how we wired the motors to the smoothie (checked the connections multiple times) also checked the wiring on the motors(red and blue are A, yellow and white are B):

Look at my working K40 + Smoothie configuration file and try it.
Your stepper values are quite different than these

1 Like