Smoothieboard looses steps then freezes (short video)

smoothie-forum
(foehnsturm_SW) #1

Today I wanted to do a extrusion speed test but I didn’t get this far.

Low karma: for a short video please type foehnsturm.com - slash - 3dp - slash - smoothie-freeze.mp4

The typical process is more or less like this:

  • (sometimes) short interruptions
  • axes, here Y, start to loose steps occasionally
  • smoothie freezes
  • LED 2 and 3 are off
  • mosfets (temp control) are still working

USB and Ethernet are disconnected,
all stepper current settings below 1.2 A,
stepper drivers feel warm but not hot,
Tried with two firmware releases (some 6 weeks old and current release)

The Gcode is a simple cylinder, spiral mode, no G2 or G3 commands.

Any ideas?

Imported from wikidot

(foehnsturm_SW) #2

There is another one
foehnsturm.com - slash - 3dp - slash - failure.mp4

I assume it might be related to SD card reading issues. But it’s the onboard card reader, the external reader is empty.
Already tried a second micro SD card as well.
Should I try do disable the external SD card reader (noise on the shared SPI channel)?

UPDATE: no success, now had a freeze with LED 1 and 3 off and mosfets shut down
But as the Reprap GLCD shows a crashed screen quite frequently today there might be a connection between the two issues?

(Arthur Wolf) #3

Can you try removing/disconnecting/removing from configuration your panel and the external sd card, and try printing the same thing over USB using Pronterface ?

(foehnsturm_SW) #4

I updated to the latest firmware (edge) and config file.

With the panel connected (external SD card not configured) the issue persists: occasionally the display crashes (weird symbols), board freezes midway during prints (like: print stops, LED 2 and 3 off for a second, then LED 1 and 3 permanently off)

Without the panel and the respective changes in config it seems to work. But still have to run a long print.

Also new: activating ethernet (with settings which used to work) will cause the board not to boot.

# network settings
network.enable                               true            # enable the ethernet network services
network.webserver.enable                     true             # enable the webserver
network.telnet.enable                        true             # enable the telnet server
#network.ip_address                           auto             # use dhcp to get ip address
# uncomment the 3 below to manually setup ip address
network.ip_address                           192.168.178.39    # the IP address
network.ip_mask                              255.255.255.0    # the ip mask
network.ip_gateway                           192.168.178.1      # the gateway address
#network.mac_override                         xx.xx.xx.xx.xx.xx  # override the mac address, only do this if you have a conflict

smoothie won’t boot at all, no green LEDs coming up.

UPDATE:

A torture test has been running now for 3 +hrs without issues.
I’d like to avoid starting another project like Octoprint at the moment. There is enough work to do for the coreXY printer and the magnetic tool changer.

Any recommendations how to get the display working reliable?
I’m a bit worried about the ethernet issue as well.

(foehnsturm_SW) #5

Any ideas on the ethernet issue?
Still cannot boot with network.enable set to “true”. Same file but set to “false” works.

(Arthur Wolf) #6

Hey.

That means your board has a problem with the Ethernet PHY, and probably needs to be replaced, really sorry about that.

Where did you buy it ?

Cheers.

(foehnsturm_SW) #7

robotseed.com, June 2015

(Arthur Wolf) #8

Hey.

Really sorry about that. Can you contact stephane@robotseed.com, say your Ethernet PHY doesn’t work, and Arthur said you need a new board.

Cheers.

(foehnsturm_SW) #9

Hey Arthur,

I’ll do that.

Thanks a lot.

(foehnsturm_SW) #10

After some thinking, I recognized the title is partly misleading.

It’s not loosing steps because there is no displacement of an axis thereafter. Instead, the print continues fine (at least for some minutes).

It’s more like skipping some line segments (gcode commands). I can reproduce the issue by turning the relative speed of my extrusion test file above 200%.

This means, smoothieware has to process approx. 150 lines per sec which look like this (spiral/vase mode):

G1 X114.863 Y126.962 Z0.404 E5.4331

So this is always moving 4 axes.
Any ideas if there could be a performance bottleneck somewhere?