Smoothie stepper chatter and movement issues

Ive recently purchased a Smoothieboard v1.1 and hooked it up-to a cartesian motion platform i’ve built.

I have flashed the latest version of the firmware onto it [firmware-latest.bin] from Git dated 2 days ago (20th May 2020) the upload process appeared to have worked with the LEDs showing a success.
I am using the latest configuration file example from the smoothie website.

I can connect via Pronterface and then when I try and move axes, the steppers start to chatter/jitter (the drivers are enabled), there is some movement and then it appears that the stepper driver is disabled and no more movement can be controlled on that axes from Pronterface until a hard reset. You can still move other axes until the same thing happens with them.
I’m only able to get slight movement too when pressing the ±0.1 and ±1mm direction arrows, any greater than that and the stepper cuts out.
The stepper motors and drivers get rather warm too whilst powered.

Ive removed the board from the machine, and connected a single stepper motor and tried with that on its own - same issue.

Im using Nema17 steppers - 1.8° 1.68A
9A 24V power supply (I have also tried running at 12v)
Steppers are wired correctly and verified

Interestingly I can’t get pronterface for mac to connect, only from Windows.
I feel like its power related, as though there is some form of current limiter kicking in, but cant be certain. Any ideas on what else to try?

Config file below:

The board i’m using has been discovered to be a clone which is why i’m probably experiencing the issues described.
I’m going to return it to the seller and try to get a refund and get hold of a genuine board.
Mods please feel free to close this topic.

There’s no “close” here, only thanks for following up with the new information. Good luck with the refund!