Sculpfun S9 Accidental Overwrite?

I was working on a project with an Arduino and connected it to my computer and proceded to push a program to it…however my Sculpfun S9 laser cutter was also connected. I believe I pushed my program to the laser cutter accidently because it no longer communicates to LightBurn…
Does anyone know how to get the proper firmware for the Sculpfun S9? I have read a couple of places that it possibly uses GRBL 1.1f.

Any info would help because Sculpfun support takes about 6 weeks to reply.

I checked the specs on the S9. If you pushed an arduino sketch to the controller without changing boards in that IDE, You should be able to push GRBL 1.1 back onto it. So, it behoves you to disconnect your laser when it is not in use, if you are working on other microcontrollers or programs that use USB ports.

Yes, I learned my lesson. I have got it back up and running. Here are the steps I did:

  1. I downloaded the latest Arduino IDE (1.8.20)
  2. I downloaded the GRBL 1.1f code from their github.
  3. I unzipped the GRBL download and put the folder “grbl” into the "libraries folder of the Arduino folder. I tried to use the import Library within the IDE but it just kept failing so I had to manually do it.
  4. In the Arduino IDE I navigated to File/Examples/grbl and selected grblUpload.
  5. I selected my USB port
  6. I pushed the upload button.
  7. Now the Sculpfun was accepting comms from Lightburn. I found someone who posted the factory default settings for the Sculpfun S9. I created a macro in LightBurn and placed the settings in it. I ran the macro and then powered off the Sculpfun S9 controller and disconnected the USB. I waited for 10 seconds then hooked everything back up and powered it up.
  8. I did a test cut and it is working!!! Woohooo

Here are the factory default settings that I found thanks to a github user nionio6915:
$12 =0.002
$13 =0
$20 =0
$21 =0
$22 =0
$23 =0
$24 =25
$25 =500
$26 =250
$27 =1
$30 =1000
$31 =0
$32 =1


Most Arduino based boards will use GRBL. Some other boards have to have a micro board plugged into them to flash the code read program as a .HEX or .BIN file, or some other method per board style.

Yes. I knew that but I just forgot to unplug all the USB’s. I have 2 laser cutters and a 3d printer plus a bunch of other USB devices. I need to make sure I have a good process for doing the Arduino uploads to Arduino’s so I don’t do this again. It was a good experience though. I feel like I understand my S9 much better now.


You can prevent this from happening again by cutting one PCB track or by adding an electrolytic capacitor or a resistor to your board’s reset circuit: How to stop Arduino from reseting after serial connection lost - Arduino Stack Exchange

1 Like