Remember awhile back when I said my hot-end started having trouble holding temperature?

Remember awhile back when I said my hot-end started having trouble holding temperature? Turns out that was probably not exactly the case.

I started a print tonight and left the printer alone in the laboratory to warm up. While I was upstairs, enough time had passed that I expected to have been hearing the whirr of the machine, but it was silent.

When I returned to the lab to see what the hold up was, smoke was pouring out of the hot-end. Before cutting the power I noticed that the realtime temperature was reporting more than 10 degrees below target (190c), but obviously the nozzle was much hotter than that :slight_smile:

I think it’s fair to say that there’s something wrong with the thermistor, that it’s reporting bogus information back to the firmware. I’m hoping I can salvage enough from the hot end (a J-Head) to get the machine working again this weekend, but I guess we’ll see.

What my take-away from this is, given the catastrophic results of this failure, maybe it would make sense to have some redundancy in the temperature metering of the nozzle? The secondary could be something much more crude than the primary thermistor, it could even be some infrared thermometer that doesn’t have physical contact with the nozzle, just something to shut down the heater when the temperature goes wildly out of range and the primary sensor is reporting that things are normal.

On a related note, is @Josef_Prusa s new nozzle out yet (or if not, any recommendations better than the J-Head)? :slight_smile:

He offered me a nozzle for testing, I initially turned him down, but have been trying to get ahold of him because me and a friend are going to do an all-metal hot-end shoot out of sorts. It’ll be PrusaNoz, vs a hot end, and a hot end.

Some people at my hackerspace are thinking of maybe starting up a video review series.

Don’t forget to add the MetalMagma to the list of candidates

I’ve heard good things about the e3d, maybe I’ll get one of those ordered just in case I can cobble something together out of my box of dead nozzles :slight_smile:

@Jason_Gullickson , have you tried contacting the guy who makes the j-heads? ( If it’s an MK-V-B, he has the PEEK bodies that I’m sure you could grab much cheaper than a whole new hot end.

That’s a good idea @ThantiK , and I’ll probably do that as well, but I also like to experiment and this is my second j-head so I might try something new :slight_smile:

Could be the thermistor, but I’d suspect the wiring connections.
It would be interesting to see what values the thermistor is reporting when the system is overheating: if you’re dumping power into the head and the thermistor output value (measured with an ADC?) isn’t changing within a couple of seconds, there’s probably a disaster going on. Do you have an LCD on the machine? It’d be interesting to have it display the raw thermistor reading so you could see when it’s going awry.

I don’t have an LCD (at the moment), but I can say I’ve seen the earlier errors (under-reported temp, but not dangerously so) using multiple host software, so it would appear that the problem goes down to at least the firmware level.

You could add on your own external(ish) sensor: a thermocouple and multimeter, or if you have the hardware, a $5 Maxim DS18S20 plugged into an Arduino, with the 18S20 taped to the hotend. That way you’d have a separate, reasonably trustworthy source for temp info. In the long term obviously you want this fixed rather than diagnosed as being screwed up before damage happens, but in the short term having an alarm might be useful.

The more work I put into my homemade hotend, the closer it gets to the e3d one. I believe they’ve made all the tight design choices and I’m pretty close to just buying theirs. Prusa, as usual, relied mostly on his instincts and less on engineery thinking, and from what I’ve seen on my hotend, the PrusaNozzle will ooze quite a bit and generally not like speed changes (like when going from infill to a perimeter or decelerating on a corner). It might also jam up on longer prints due to the filament melting too far up in the stainless insulator.

@John_Bump iirc, Marlin can already monitor temperature rise when heating and shut the whole bot down if necessary. Redundant temperature sensing would be the gold standard, though.

Yeah, the same exact thing happened to me actually!

Im still trying to resolve this and im new to the community of 3d printing. I checked the resistance on the thermistor and it changed as the temp went up. So I don’t think its the thermistor.

My room still stinks like burnt plastic lol

Yeah @Matthew_garsteck I know the value was changing (the firmware would have caught it if it was outside of “sane” ranges) but it seemed to change “wrong”. It’s as if it were entering some failure mode where the values it was returning were “reasonable”, but inaccurate.

@Jason_Gullickson now that I think about it, I’ve seen that behavior, too. I was trying to calibrate three thermistors and attached them to a single aluminum plate, along with a known-good thermocouple. One of the thermistors would randomly drop into a state where it would report a lower temp. Most of the time this would not cause issues since it would only briefly remain in the faulty state and the control loop then shut the thing off long enough to get back to sane temperatures in time.

From the sounds of that last post, it would seem there is a thermal barrier (i.e. separation) between the thermistor and what it is trying to measure. (Guessing at the geometry here) From the nozzle to the thermistor there are only a couple of interfaces - nozzle-to-threaded rod, threaded rod-to-heater block, heater block-to-thermistor package, thermistor package-to-thermistor. One of those has more thermal resistance than normal. Extracting the thermistor package from the heater block and somehow reshaping it to fit better, or adding a bit of aluminum foil or more thermal paste and re-seating it should fix it.

@Derrick_Oswald_curmu thermal resistance is hardly an issue with thermistors, as the energy/power transferred to the thermistor is pretty much negligible. It’s much more of an issue when there is a large amount of power to be transferred, like the contact from the resistor to the block.

@Thomas_Sanladerer true, it’s important to minimize the thermal resistance when transferring power, but it seems in this case that there is enough thermal resistance between the measured and measuring device to cause significant errors - either not enough cross-sectional contact or a longer length of material to pass through and I’m guessing the former.

fwiw in my case, the measurements seemed to change at a certain point in time, when no (known) changes were made to the position, mounting, etc. of the thermistor. In other words, it worked correctly for a long time, then one day started acting up :slight_smile:

Makerbot Mk7’s have an independent thermal cutoff (which later extruders removed) - despite reports of some people having experienced false triggers cutting off the extruder, it still seems like a good idea. One can easily assemble a similar thermal cutoff device to protect against a thermal runaway.

I would guess that you have some extra resistance somewhere in your wiring. Oxidized contacts, maybe? This is also a plausible failure mode if the glass bead of your thermistor cracked, and the two pieces slowly pulled themselves appart with repeated heating/cooling. Another possibility is a partial short within the reference resistor, though this would be more likely if it had any appreciable current running though it during normal operation.

You’re sure you didn’t accidentally re-flash the firmware with the wrong thermistor table?

and you should add a smoke alarm; you may have heard the noise before too much damage was done.